
CVE catalog
CVE-2025-6927
mediawiki affected and fixed versions
Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/specials/pagers/BlockListPager.Php, includes/api/ApiQueryBlocks.Php. This issue affects MediaWiki: from >= 1.42.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.52% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "mediawiki",
"status": "fixed",
"release": "sid",
"version": "1:1.43.11+dfsg-3"
},
{
"name": "mediawiki",
"status": "fixed",
"release": "forky",
"version": "1:1.43.11+dfsg-1"
},
{
"name": "mediawiki",
"status": "fixed",
"release": "trixie",
"version": "1:1.43.9+dfsg-1~deb13u1"
},
{
"name": "mediawiki",
"status": "fixed",
"release": "trixie-security",
"version": "1:1.43.9+dfsg-1~deb13u1"
},
{
"name": "mediawiki",
"status": "not affected",
"release": "bookworm",
"version": "1:1.39.17-1+deb12u2"
},
{
"name": "mediawiki",
"status": "not affected",
"release": "bookworm-security",
"version": "1:1.39.17-1+deb12u2"
}
],
"fixed_versions": [
{
"bug": null,
"name": "mediawiki",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "1:1.43.3+dfsg-1"
},
{
"bug": null,
"name": "mediawiki",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "1:1.43.3+dfsg-1"
},
{
"bug": null,
"name": "mediawiki",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "1:1.43.3+dfsg-1"
},
{
"bug": null,
"name": "mediawiki",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "unimportant",
"fixed_version": "0"
}
],
"distribution_packages": []
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [mediawiki]Unknown
Details (4)
1:1.39.17-1+deb12u2· all · bookwormNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookwormNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookworm-securityNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookworm-securityNot affected
dsa · mediawiki · debian · bookworm
- [mediawiki-classes]Unknown
Source package: [mediawiki]
Details (4)
1:1.39.17-1+deb12u2· all · bookwormNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookwormNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookworm-securityNot affected
dsa · mediawiki · debian · bookworm
1:1.39.17-1+deb12u2· all · bookworm-securityNot affected
dsa · mediawiki · debian · bookworm
[Debian 13 (Trixie)]
- [mediawiki]Unknown
Details (4)
1:1.43.9+dfsg-1~deb13u1· all · trixieFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixieFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixie-securityFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixie-securityFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
- [mediawiki-classes]Unknown
Source package: [mediawiki]
Details (4)
1:1.43.9+dfsg-1~deb13u1· all · trixieFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixieFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixie-securityFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
1:1.43.9+dfsg-1~deb13u1· all · trixie-securityFixed · Fixed:
1:1.43.3+dfsg-1dsa · mediawiki · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-6927]
- [https://security-tracker.debian.org/tracker/CVE-2025-6927]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-6927.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2025/wid-sec-w-2025-1438.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]