
CVE catalog
CVE-2025-69873
node-ajv: CVE-2025-69873
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.55% · Oct 25, 2026
ajv (Another JSON Schema Validator) before 8.18.0 is vulnerable to Regular Expression Denial of Service (ReDoS) when the $data option is enabled. The pattern keyword accepts runtime data via JSON Pointer syntax ($data reference), which is passed directly to the JavaScript RegExp() constructor without validation. An attacker can inject a malicious regex pattern (e.g., "^(a|a)*$") combined with crafted input to cause catastrophic backtracking. A 31-character payload causes approximately 44 seconds of CPU blocking, with each additional character doubling execution time. This enables complete denial of service with a single HTTP request against any API using ajv with $data: true for dynamic schema validation. This issue is also fixed in version 6.14.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-ajv | sid | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | forky | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | trixie | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Debian | node-ajv | bookworm | 6.12.6-3 | vulnerable |
| Npm | ajv | Not reported | 6.14.0 | fixed |
| Npm | ajv | Not reported | 6.14.0 | fixed |
| Ubuntu | node-ajv | 18.04 | 5.0.0-1 | vulnerable |
| Ubuntu | node-ajv | 20.04 | 6.10.2-1 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-2 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 8.12.0~ds+~2.1.1-4 | vulnerable |
| Ubuntu | node-ajv | 25.10 | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs6.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.2-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-3 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-2 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-ajv | source | sid | 8.18.0~ds+~cs6.1.1-1 | not yet assigned | Not reported | [1128140] |
| Debian | node-ajv | source | forky | 8.18.0~ds+~cs6.1.1-1 | not yet assigned | Not reported | [1128140] |
| Debian | node-ajv | source | trixie | (unfixed) | not yet assigned | Not reported | [1128140] |
| Debian | node-ajv | source | bookworm | (unfixed) | not yet assigned | Not reported | [1128140] |
| Npm | ajv | npm | Not reported | 6.14.0 | Not reported | GHSA-2G4F-4PWH-QVX6 | Not reported |
| Npm | ajv | npm | Not reported | 6.14.0 | Not reported | Not reported | Not reported |
Notes
[trixie] node-ajv: Minor issue [bookworm] node-ajv: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-ajv]Affected
Details (2)
6.12.6-3· all · bookwormAffected
dsa · node-ajv · debian · bookworm; dsa · node-ajv · debian · 12
6.12.6-3· all · bookwormAffected
dsa · node-ajv · debian · bookworm; dsa · node-ajv · debian · 12
[Debian 13 (Trixie)]
- [node-ajv]Affected
Details (2)
8.12.0~ds+~2.1.1-5· all · trixieAffected
dsa · node-ajv · debian · 13
8.12.0~ds+~2.1.1-5· all · trixieAffected
dsa · node-ajv · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2025-69873]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2025-69873]
- [https://osv.dev/vulnerability/GHSA-2g4f-4pwh-qvx6]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2025-69873]
- [https://security-tracker.debian.org/tracker/CVE-2025-69873]
- [https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-69873.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-0778.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]