
CVE catalog
CVE-2025-71240
UBUNTU-
SPIP before 4.2.15 allows Cross-Site Scripting (XSS) via crafted content in HTML code tags. The application does not properly verify JavaScript within code tags, allowing an attacker to inject malicious scripts that execute in a victim's browser.
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.20% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "spip",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.0+dfsg-1"
}
]
}
],
"release": "13",
"versions": [],
"ecosystem": "deb",
"fixed_version": "4.3.0+dfsg-1",
"provider_record_id": "DEBIAN-CVE-2025-71240"
},
{
"name": "spip",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.3.0+dfsg-1"
}
]
}
],
"release": "14",
"versions": [],
"ecosystem": "deb",
"fixed_version": "4.3.0+dfsg-1",
"provider_record_id": "DEBIAN-CVE-2025-71240"
},
{
"name": "spip",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"3.2.4-1",
"3.2.5-1",
"3.2.7-1",
"3.2.7-1ubuntu0.1",
"3.2.7-1ubuntu0.1+esm2"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2025-71240"
},
{
"name": "spip",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "22.04",
"versions": [
"3.2.11-3",
"3.2.12-1",
"4.0.2-1",
"4.0.4-1"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2025-71240"
},
{
"name": "spip",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "24.04",
"versions": [
"4.1.11+dfsg-1",
"4.1.12+dfsg-1",
"4.1.13+dfsg-1",
"4.1.15+dfsg-1",
"4.2.9+dfsg-2"
],
"ecosystem": "deb",
"fixed_version": "",
"provider_record_id": "UBUNTU-CVE-2025-71240"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 13 (Trixie)]
- [spip]Unknown
Details (9)
4.4.15+dfsg-0+deb13u1· all · trixieFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.15+dfsg-0+deb13u1· all · trixieFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.15+dfsg-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.19+dfsg-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.20+dfsg-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.21+dfsg-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.21+dfsg-0+deb13u1· all · trixie-securityFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.23+dfsg-0+deb13u1· all · trixie-security · Historical versionFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
4.4.28+dfsg-0+deb13u1· all · trixie-securityFixed · Fixed:
4.3.0+dfsg-1pypi · spip · debian · 13
Observed: