CVE catalog

CVE-2026-100696

Adminer 4.16.0 through 6.0.1 contain a pre-authentication Server-Side Request Forgery (SSRF) vulnerability in the optional Elasticsearch driver (plugins/drivers/elastic.php), fixed in 6.0.2. Because a

[CVE catalog]

Severity
Medium · CVSS 6.9CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.39% · Oct 25, 2026

Adminer 4.16.0 through 6.0.1 contain a pre-authentication Server-Side Request Forgery (SSRF) vulnerability in the optional Elasticsearch driver (plugins/drivers/elastic.php), fixed in 6.0.2. Because adminer/include/auth.inc.php invokes Driver::connect() before the login result is validated, an unauthenticated attacker who submits crafted auth[server], auth[username], and auth[password] parameters can cause the Adminer server to issue an HTTP GET request (via get_url()/file_get_contents()) to an arbitrary reachable host and port. The driver validates only general server syntax and does not block loopback, private, link-local, or other reserved addresses; if no port is given it appends the default 9200, and Adminer's generic port check rejects ports below 1024. Selected JSON error fields from non-2xx Elasticsearch-style responses, as well as connection failures, are rendered on the login page, providing a port-scanning oracle and enabling internal network reconnaissance and service fingerprinting. Exploitation requires that the optional Elasticsearch driver be explicitly deployed (e.g., via the adminer/elastic.php template or an adminer_object() configuration; it is not loaded in a default build) and that PHP allow_url_fopen be enabled.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianadminersid6.1.2-1fixed
Debianadminerforky6.1.0-1fixed
Debianadminertrixie5.2.1+dfsg-1vulnerable
Debianadminerbookworm4.8.1-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianadminersourcesid6.0.2-1not yet assignedNot reportedNot reported
Debianadminersourceforky6.0.2-1not yet assignedNot reportedNot reported
Debianadminersourcetrixie(unfixed)not yet assignedNot reportedNot reported
Debianadminersourcebookworm(unfixed)not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [adminer]Affected
    Details (2)
    • 4.8.1-1 · all · bookworm

      Affected

      nvd · adminer · debian · bookworm; nvd · adminer · debian · 12

    • 4.8.1-1 · all · bookworm

      Affected

      nvd · adminer · debian · bookworm; nvd · adminer · debian · 12

[Debian 13 (Trixie)]

  • [adminer]Affected
    Details (2)
    • 5.2.1+dfsg-1 · all · trixie

      Affected

      nvd · adminer · debian · 13

    • 5.2.1+dfsg-1 · all · trixie

      Affected

      nvd · adminer · debian · 13

Observed:

References