
CVE catalog
CVE-2026-102276
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCo
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.46% · Oct 25, 2026
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-brace-expansion | sid | 2.1.7+~1.1.2-1 | fixed |
| Debian | node-brace-expansion | forky | 2.1.7+~1.1.2-1 | fixed |
| Debian | node-brace-expansion | trixie | 2.0.1+~1.1.0-2 | vulnerable |
| Debian | node-brace-expansion | bookworm | 2.0.1-2 | vulnerable |
| Npm | brace-expansion | Not reported | 1.1.19 | fixed |
| Opensuse | pi-coding-agent | tumbleweed | 1.0.2-1.1 | fixed |
| Opensuse | pi-coding-agent | leap 16.0 | 1.0.4-bp160.1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-brace-expansion | source | sid | 2.1.7+~1.1.2-1 | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | forky | 2.1.7+~1.1.2-1 | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | trixie | (unfixed) | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | bookworm | (unfixed) | not yet assigned | Not reported | [1149649] |
| Npm | brace-expansion | npm | Not reported | 1.1.19 | Not reported | GHSA-6J4F-FJ2G-MC7P | Not reported |
| Opensuse | pi-coding-agent | rpm | tumbleweed | 1.0.2-1.1 | Not reported | OPENSUSE-SU-2026:12062-1 | Not reported |
| Opensuse | pi-coding-agent | rpm | leap 16.0 | 1.0.4-bp160.1.1 | Not reported | OPENSUSE-SU-2026:22111-1 | Not reported |
Notes
[trixie] node-brace-expansion: Minor issue [bookworm] node-brace-expansion: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-brace-expansion]Affected
Details (2)
2.0.1-2· all · bookwormAffected
nvd · node-brace-expansion · debian · bookworm; nvd · node-brace-expansion · debian · 12
2.0.1-2· all · bookwormAffected
nvd · node-brace-expansion · debian · bookworm; nvd · node-brace-expansion · debian · 12
[Debian 13 (Trixie)]
- [node-brace-expansion]Affected
Details (2)
2.0.1+~1.1.0-2· all · trixieAffected
nvd · node-brace-expansion · debian · 13
2.0.1+~1.1.0-2· all · trixieAffected
nvd · node-brace-expansion · debian · 13
[openSUSE Tumbleweed]
- [pi-coding-agent]Affected
Source package: [pi-coding-agent]
Details (1)
0.84.4-1.1· noarch · tumbleweedAffected · Fixed:
1.0.2-1.1nvd · pi-coding-agent · opensuse · tumbleweed
- [pi-coding-agent-examples]Unknown
Source package: [pi-coding-agent]
Details (1)
0.84.4-1.1· noarch · tumbleweedUnknown · Fixed:
1.0.2-1.1Version impact unknown
nvd · pi-coding-agent · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_12062-1.json]
- [https://github.com/advisories/GHSA-6j4f-fj2g-mc7p]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-102276]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-102276]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:12062-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:22111-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-102276]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102276.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]