
CVE catalog
CVE-2026-102278
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.46% · Oct 25, 2026
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-brace-expansion | sid | 2.1.7+~1.1.2-1 | fixed |
| Debian | node-brace-expansion | forky | 2.1.7+~1.1.2-1 | fixed |
| Debian | node-brace-expansion | trixie | 2.0.1+~1.1.0-2 | vulnerable |
| Debian | node-brace-expansion | bookworm | 2.0.1-2 | vulnerable |
| Npm | brace-expansion | Not reported | 1.1.20 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-brace-expansion | source | sid | 2.1.7+~1.1.2-1 | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | forky | 2.1.7+~1.1.2-1 | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | trixie | (unfixed) | not yet assigned | Not reported | [1149649] |
| Debian | node-brace-expansion | source | bookworm | (unfixed) | not yet assigned | Not reported | [1149649] |
| Npm | brace-expansion | npm | Not reported | 1.1.20 | Not reported | GHSA-QHR7-859C-M2P7 | Not reported |
Notes
[trixie] node-brace-expansion: Minor issue [bookworm] node-brace-expansion: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-brace-expansion]Affected
Details (2)
2.0.1-2· all · bookwormAffected
nvd · node-brace-expansion · debian · bookworm; nvd · node-brace-expansion · debian · 12
2.0.1-2· all · bookwormAffected
nvd · node-brace-expansion · debian · bookworm; nvd · node-brace-expansion · debian · 12
[Debian 13 (Trixie)]
- [node-brace-expansion]Affected
Details (2)
2.0.1+~1.1.0-2· all · trixieAffected
nvd · node-brace-expansion · debian · 13
2.0.1+~1.1.0-2· all · trixieAffected
nvd · node-brace-expansion · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11967-1.json]
- [https://github.com/advisories/GHSA-qhr7-859c-m2p7]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-102278]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-102278]
- [https://security-tracker.debian.org/tracker/CVE-2026-102278]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102278.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]