
CVE catalog
CVE-2026-105263
A security flaw has been discovered in Shaarli up to 0.16.3. The affected element is the function MetadataController of the file application/front/controller/admin/MetadataController.php of the compon
- Severity
- Medium · CVSS 5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.23% · Oct 25, 2026
A security flaw has been discovered in Shaarli up to 0.16.3. The affected element is the function MetadataController of the file application/front/controller/admin/MetadataController.php of the component Admin Metadata Endpoint. Performing a manipulation of the argument url results in server-side request forgery. The attack may be initiated remotely. Upgrading to version 0.16.4 is sufficient to fix this issue. The patch is named 8ca4de8e7c932a684481f5fbb1229fe16de1f4d2. It is advisable to upgrade the affected component.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | shaarli | sid | 0.16.1+dfsg-1 | vulnerable |
| Debian | shaarli | trixie | 0.14.0+dfsg-2+deb13u1 | vulnerable |
| Debian | shaarli | trixie-security | 0.14.0+dfsg-2+deb13u1 | vulnerable |
| Debian | shaarli | bookworm | 0.12.1+dfsg-8+deb12u2 | vulnerable |
| Debian | shaarli | bookworm-security | 0.12.1+dfsg-8+deb12u2 | vulnerable |
| Ubuntu | shaarli | 16.04 | 0.0.42~beta~dfsg1-2 | vulnerable |
| Ubuntu | shaarli | 16.04 | 0.0.42~beta~dfsg1-2ubuntu1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [shaarli]Affected
Details (4)
0.12.1+dfsg-8+deb12u2· all · bookwormAffected
nvd · shaarli · debian · bookworm; nvd · shaarli · debian · 12
0.12.1+dfsg-8+deb12u2· all · bookwormAffected
nvd · shaarli · debian · bookworm; nvd · shaarli · debian · 12
0.12.1+dfsg-8+deb12u2· all · bookworm-securityAffected
nvd · shaarli · debian · bookworm; nvd · shaarli · debian · 12
0.12.1+dfsg-8+deb12u2· all · bookworm-securityAffected
nvd · shaarli · debian · bookworm; nvd · shaarli · debian · 12
[Debian 13 (Trixie)]
- [shaarli]Affected
Details (4)
0.14.0+dfsg-2+deb13u1· all · trixieAffected
nvd · shaarli · debian · 13
0.14.0+dfsg-2+deb13u1· all · trixieAffected
nvd · shaarli · debian · 13
0.14.0+dfsg-2+deb13u1· all · trixie-securityAffected
nvd · shaarli · debian · 13
0.14.0+dfsg-2+deb13u1· all · trixie-securityAffected
nvd · shaarli · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-105263]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-105263]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-105263]
- [https://security-tracker.debian.org/tracker/CVE-2026-105263]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]