
CVE catalog
CVE-2026-109841
node-undici: CVE-2026-109841
- Severity
- Medium · CVSS 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.25% · Oct 25, 2026
undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-undici | sid | 8.12.2+dfsg+~cs3.2.3-2 | fixed |
| Debian | node-undici | forky | 8.10.2+dfsg+~cs3.2.2-1 | vulnerable |
| Debian | node-undici | trixie | 7.3.0+dfsg1+~cs24.12.11-1 | not affected |
| Debian | node-undici | bookworm | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4 | not affected |
| Debian | node-undici | bookworm-security | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3 | not affected |
| Cpe | undici | Not reported | 8.12.2 | fixed |
| Ubuntu | node-undici | 24.04 | 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1 | vulnerable |
| Ubuntu | node-undici | 24.04 | 5.26.3+dfsg1+~cs23.10.12-2 | vulnerable |
| Ubuntu | node-undici | 26.10 | 7.18.2+dfsg+~cs3.2.0-1build1 | vulnerable |
| Ubuntu | node-undici | 26.10 | 7.24.6+dfsg+~cs3.2.0-3 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.5.0+dfsg+~cs3.2.0-2 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.5.0+dfsg+~cs3.2.0-3 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.9.0+dfsg+~cs3.2.0-1 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.3.0+dfsg1+~cs24.12.11-2 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.16.0+dfsg+~cs3.2.0-2 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.18.2+dfsg+~cs3.2.0-1 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.18.2+dfsg+~cs3.2.0-1build1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-undici | source | sid | 8.12.2+dfsg+~cs3.2.3-1 | not yet assigned | Not reported | Not reported |
| Debian | node-undici | source | forky | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | node-undici | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | node-undici | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| Cpe | undici | cpe | Not reported | 8.12.2 | Not reported | NVD-CVE-2026-109841 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-llhttp]Not affected
Source package: [node-undici]
Details (4)
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
dsa · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
dsa · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
dsa · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
dsa · node-undici · debian · bookworm
- [node-undici]Not affected
Details (4)
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
dsa · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
dsa · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
dsa · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
dsa · node-undici · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-109841]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-109841]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-109841]
- [https://security-tracker.debian.org/tracker/CVE-2026-109841]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-109841.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]