
CVE catalog
CVE-2026-109855
undici is an HTTP client library for Node.js. In…
undici is an HTTP client library for Node.js. In versions 8.11.0 and 8.11.1, its experimental WebSocket client, which is enabled by default when HTTP/2 is allowed, mishandles a failed WebSocket handshake over HTTP/2: the request is already marked completed, so the abort becomes a no-op and the underlying HTTP/2 stream is left open with no error listener. When a malicious server then destroys the connection, the orphaned stream emits an unhandled error and the Node.js process exits. A remote, unauthenticated server can therefore crash any client that opens a WebSocket to it over HTTP/2, resulting in a denial of service. The issue is fixed in undici 8.11.2, and users should upgrade to 8.11.2 or later. As a workaround, set allowH2 to false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers.
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.28% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "node-undici",
"status": "fixed",
"release": "sid",
"version": "8.12.2+dfsg+~cs3.2.3-2"
},
{
"name": "node-undici",
"status": "vulnerable",
"release": "forky",
"version": "8.10.2+dfsg+~cs3.2.2-1"
},
{
"name": "node-undici",
"status": "not affected",
"release": "trixie",
"version": "7.3.0+dfsg1+~cs24.12.11-1"
},
{
"name": "node-undici",
"status": "not affected",
"release": "bookworm",
"version": "5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4"
},
{
"name": "node-undici",
"status": "not affected",
"release": "bookworm-security",
"version": "5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3"
}
],
"fixed_versions": [
{
"bug": null,
"name": "node-undici",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "8.12.2+dfsg+~cs3.2.3-1"
},
{
"bug": null,
"name": "node-undici",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": ""
},
{
"bug": null,
"name": "node-undici",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "unimportant",
"fixed_version": "0"
},
{
"bug": null,
"name": "node-undici",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "unimportant",
"fixed_version": "0"
}
],
"distribution_packages": [
{
"name": "undici",
"ranges": [
{
"fixed": "8.11.2",
"introduced": "8.11.0",
"last_affected": "",
"start_excluding": ""
}
],
"ecosystem": "cpe",
"fixed_version": "8.11.2",
"provider_record_id": "NVD-CVE-2026-109855"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [node-llhttp]Unknown
Source package: [node-undici]
Details (4)
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
nvd · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
nvd · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
nvd · node-undici · debian · bookworm
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
nvd · node-undici · debian · bookworm
- [node-undici]Unknown
Details (4)
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
nvd · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormNot affected
nvd · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
nvd · node-undici · debian · bookworm
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityNot affected
nvd · node-undici · debian · bookworm
Observed:
References
- [https://access.redhat.com/errata/RHSA-2026:76677]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-109855]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-109855]
- [https://security-tracker.debian.org/tracker/CVE-2026-109855]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]