
CVE catalog
CVE-2026-109924
node-undici: CVE-2026-109924
- Severity
- Medium · CVSS 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.32% · Oct 25, 2026
undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-undici | sid | 8.12.2+dfsg+~cs3.2.3-2 | fixed |
| Debian | node-undici | forky | 8.10.2+dfsg+~cs3.2.2-1 | vulnerable |
| Debian | node-undici | trixie | 7.3.0+dfsg1+~cs24.12.11-1 | vulnerable |
| Debian | node-undici | bookworm | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4 | vulnerable |
| Debian | node-undici | bookworm-security | 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3 | vulnerable |
| Cpe | undici | Not reported | 8.12.2 | fixed |
| Ubuntu | node-undici | 24.04 | 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1 | vulnerable |
| Ubuntu | node-undici | 24.04 | 5.26.3+dfsg1+~cs23.10.12-2 | vulnerable |
| Ubuntu | node-undici | 26.10 | 7.18.2+dfsg+~cs3.2.0-1build1 | vulnerable |
| Ubuntu | node-undici | 26.10 | 7.24.6+dfsg+~cs3.2.0-3 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.5.0+dfsg+~cs3.2.0-2 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.5.0+dfsg+~cs3.2.0-3 | vulnerable |
| Ubuntu | node-undici | 26.10 | 8.9.0+dfsg+~cs3.2.0-1 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.3.0+dfsg1+~cs24.12.11-2 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.16.0+dfsg+~cs3.2.0-2 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.18.2+dfsg+~cs3.2.0-1 | vulnerable |
| Ubuntu | node-undici | 26.04 | 7.18.2+dfsg+~cs3.2.0-1build1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-undici | source | sid | 8.12.2+dfsg+~cs3.2.3-1 | not yet assigned | Not reported | Not reported |
| Debian | node-undici | source | forky | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | node-undici | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | node-undici | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Cpe | undici | cpe | Not reported | 8.12.2 | Not reported | NVD-CVE-2026-109924 | Not reported |
Notes
[trixie] node-undici: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-llhttp]Affected
Source package: [node-undici]
Details (4)
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
8.1.0~5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
- [node-undici]Affected
Details (4)
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4· all · bookwormAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3· all · bookworm-securityAffected
dsa · node-undici · debian · bookworm; dsa · node-undici · debian · 12
[Debian 13 (Trixie)]
- [libllhttp9.2]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· amd64 · trixieAffected
dsa · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· arm64 · trixieAffected
dsa · node-undici · debian · 13
- [libllhttp-dev]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· amd64 · trixieAffected
dsa · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· arm64 · trixieAffected
dsa · node-undici · debian · 13
- [node-llhttp]Affected
Source package: [node-undici]
Details (2)
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
dsa · node-undici · debian · 13
9.2.1~7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
dsa · node-undici · debian · 13
- [node-undici]Affected
Details (2)
7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
dsa · node-undici · debian · 13
7.3.0+dfsg1+~cs24.12.11-1· all · trixieAffected
dsa · node-undici · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-109924]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-109924]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-109924]
- [https://security-tracker.debian.org/tracker/CVE-2026-109924]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-109924.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]