
CVE catalog
CVE-2026-110095
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() function
- Severity
- Low · CVSS 3.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.29% · Oct 25, 2026
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-ajv | sid | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | forky | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | trixie | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Debian | node-ajv | bookworm | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 18.04 | 5.0.0-1 | vulnerable |
| Ubuntu | node-ajv | 20.04 | 6.10.2-1 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-2 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 8.12.0~ds+~2.1.1-4 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs6.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.2-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-3 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-2 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
| Opensuse | git-bug | tumbleweed | 0.11.0-3.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-ajv | source | sid | 8.20.0~ds+~cs7.2.4-1 | not yet assigned | Not reported | Not reported |
| Debian | node-ajv | source | forky | 8.20.0~ds+~cs7.2.4-1 | not yet assigned | Not reported | Not reported |
| Debian | node-ajv | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | node-ajv | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Opensuse | git-bug | rpm | tumbleweed | 0.11.0-3.1 | Not reported | OPENSUSE-SU-2026:12261-1 | Not reported |
Notes
[trixie] node-ajv: Minor issue [bookworm] node-ajv: Minor issue; can be fixed in next update
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-ajv]Affected
Details (2)
6.12.6-3· all · bookwormAffected
nvd · node-ajv · debian · bookworm; nvd · node-ajv · debian · 12
6.12.6-3· all · bookwormAffected
nvd · node-ajv · debian · bookworm; nvd · node-ajv · debian · 12
[Debian 13 (Trixie)]
- [node-ajv]Affected
Details (2)
8.12.0~ds+~2.1.1-5· all · trixieAffected
nvd · node-ajv · debian · 13
8.12.0~ds+~2.1.1-5· all · trixieAffected
nvd · node-ajv · debian · 13
[openSUSE Tumbleweed]
- [git-bug]Affected
Source package: [git-bug]
Details (1)
0.10.1-6.3· x86_64 · tumbleweedAffected · Fixed:
0.11.0-3.1nvd · git-bug · opensuse · tumbleweed
- [git-bug-bash-completion]Unknown
Source package: [git-bug]
Details (1)
0.10.1-6.3· noarch · tumbleweedUnknown · Fixed:
0.11.0-3.1Version impact unknown
nvd · git-bug · opensuse · tumbleweed
- [git-bug-fish-completion]Unknown
Source package: [git-bug]
Details (1)
0.10.1-6.3· noarch · tumbleweedUnknown · Fixed:
0.11.0-3.1Version impact unknown
nvd · git-bug · opensuse · tumbleweed
- [git-bug-zsh-completion]Unknown
Source package: [git-bug]
Details (1)
0.10.1-6.3· noarch · tumbleweedUnknown · Fixed:
0.11.0-3.1Version impact unknown
nvd · git-bug · opensuse · tumbleweed
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-110095]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-110095]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-110095]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:12261-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-110095]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-110095.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]