
CVE catalog
CVE-2026-110180
node-ajv: CVE-2026-110180
- Severity
- Medium · CVSS 4.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.26% · Oct 27, 2026
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-ajv | sid | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | forky | 8.20.0~ds+~cs7.2.4-1 | fixed |
| Debian | node-ajv | trixie | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Debian | node-ajv | bookworm | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 18.04 | 5.0.0-1 | vulnerable |
| Ubuntu | node-ajv | 20.04 | 6.10.2-1 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-2 | vulnerable |
| Ubuntu | node-ajv | 22.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 6.12.6-3 | vulnerable |
| Ubuntu | node-ajv | 24.04 | 8.12.0~ds+~2.1.1-4 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs6.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.2-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-1 | vulnerable |
| Ubuntu | node-ajv | 26.10 | 8.20.0~ds+~cs7.1.3-3 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.12.0~ds+~2.1.1-5 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-2 | vulnerable |
| Ubuntu | node-ajv | 26.04 | 8.17.1~ds+~3.0.1+~3.1.0-4build1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-ajv | source | sid | 8.20.0~ds+~cs7.2.4-1 | not yet assigned | Not reported | [1151875] |
| Debian | node-ajv | source | forky | 8.20.0~ds+~cs7.2.4-1 | not yet assigned | Not reported | [1151875] |
| Debian | node-ajv | source | trixie | (unfixed) | not yet assigned | Not reported | [1151875] |
| Debian | node-ajv | source | bookworm | (unfixed) | not yet assigned | Not reported | [1151875] |
Notes
[trixie] node-ajv: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-ajv]Affected
Details (2)
6.12.6-3· all · bookwormAffected
dsa · node-ajv · debian · bookworm; dsa · node-ajv · debian · 12
6.12.6-3· all · bookwormAffected
dsa · node-ajv · debian · bookworm; dsa · node-ajv · debian · 12
[Debian 13 (Trixie)]
- [node-ajv]Affected
Details (2)
8.12.0~ds+~2.1.1-5· all · trixieAffected
dsa · node-ajv · debian · 13
8.12.0~ds+~2.1.1-5· all · trixieAffected
dsa · node-ajv · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-110180]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-110180]
- [https://security-tracker.debian.org/tracker/CVE-2026-110180]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-110180.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]