
CVE catalog
CVE-2026-112945
UBUNTU-CVE-2026-112945
- Severity
- Low · CVSS 2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.56% · Oct 27, 2026
Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | vite | 16.04 | 1.2+svn1430-2 | vulnerable |
| Ubuntu | vite | 16.04 | 1.2+svn1430-3 | vulnerable |
| Ubuntu | vite | 16.04 | 1.2+svn1430-4 | vulnerable |
| Ubuntu | vite | 16.04 | 1.2+svn1430-5 | vulnerable |
| Ubuntu | vite | 18.04 | 1.2+svn1430-5 | vulnerable |
| Ubuntu | vite | 18.04 | 1.2+svn1430-6 | vulnerable |
| Ubuntu | vite | 20.04 | 1.2+svn1430-6 | vulnerable |
| Ubuntu | vite | 20.04 | 1.2+svn1430-6build1 | vulnerable |
| Ubuntu | vite | 22.04 | 1.2+svn+git4.c6c0ce7-3 | vulnerable |
| Ubuntu | vite | 22.04 | 1.2+svn+git4.c6c0ce7-4 | vulnerable |
| Ubuntu | vite | 24.04 | 1.2+svn+git4.c6c0ce7-8 | vulnerable |
| Ubuntu | vite | 24.04 | 1.2+svn+git4.c6c0ce7-8build1 | vulnerable |
| Ubuntu | vite | 24.04 | 1.2+svn+git4.c6c0ce7-8build2 | vulnerable |
| Ubuntu | vite | 26.10 | 1.4-6 | vulnerable |
| Ubuntu | vite | 26.10 | 1.4-6build1 | vulnerable |
| Ubuntu | vite | 26.04 | 1.4-1 | vulnerable |
| Ubuntu | vite | 26.04 | 1.4-5 | vulnerable |
| Ubuntu | vite | 26.04 | 1.4-5build1 | vulnerable |
| Ubuntu | vite | 26.04 | 1.4-6 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/vitejs/vite/commit/7dafd8e56f152403a3230608fa4005273c2e9e17]
- [https://github.com/vitejs/vite/pull/23653]
- [https://github.com/vitejs/vite/security/advisories/GHSA-9jrq-w75r-8gcw]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-112945]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-112945]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]