
CVE catalog
CVE-2026-113790
pypdf: CVE-2026-113790
- Severity
- Medium · CVSS 5.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.39% · Oct 25, 2026
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.0, an attacker can craft a PDF containing arrays or dictionaries with many elements, causing parsing to consume large amounts of memory. This issue is fixed in version 6.21.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | pypdf | sid | 6.21.1-1 | fixed |
| Debian | pypdf | forky | 6.21.1-1 | fixed |
| Debian | pypdf | trixie | 5.4.0-1 | vulnerable |
| Debian | pypdf | bookworm | 3.4.1-1+deb12u1 | vulnerable |
| Debian | pypdf2 | bookworm | 2.12.1-3+deb12u1 | vulnerable |
| Ubuntu | pypdf2 | pro | 1.26.0-2 | vulnerable |
| Ubuntu | pypdf2 | pro | 1.26.0-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | pypdf2 | pro | 1.26.0-2ubuntu0.1~esm2 | vulnerable |
| Ubuntu | pypdf2 | 20.04 | 1.26.0-2 | vulnerable |
| Ubuntu | pypdf2 | 20.04 | 1.26.0-3ubuntu1 | vulnerable |
| Ubuntu | pypdf2 | 20.04 | 1.26.0-3ubuntu1.20.04.1 | vulnerable |
| Ubuntu | pypdf2 | 20.04 | 1.26.0-3ubuntu1.20.04.2 | vulnerable |
| Ubuntu | pypdf2 | 22.04 | 1.26.0-4 | vulnerable |
| Ubuntu | pypdf2 | 22.04 | 1.26.0-4ubuntu0.22.04.1 | vulnerable |
| Ubuntu | pypdf2 | 22.04 | 1.26.0-4ubuntu0.22.04.2 | vulnerable |
| Ubuntu | pypdf | 24.04 | 3.4.1-1 | vulnerable |
| Ubuntu | pypdf | 24.04 | 3.17.4-1 | vulnerable |
| Ubuntu | pypdf | 24.04 | 4.0.0-1 | vulnerable |
| Ubuntu | pypdf | 24.04 | 4.0.1-1 | vulnerable |
| Ubuntu | pypdf | 24.04 | 4.0.2-1 | vulnerable |
| Ubuntu | pypdf2 | 24.04 | 2.12.1-3 | vulnerable |
| Ubuntu | pypdf2 | 24.04 | 2.12.1-4 | vulnerable |
| Ubuntu | pypdf | 26.10 | 6.9.2-1 | vulnerable |
| Ubuntu | pypdf | 26.10 | 6.9.2-2 | vulnerable |
| Ubuntu | pypdf | 26.04 | 5.4.0-1 | vulnerable |
| Ubuntu | pypdf | 26.04 | 6.9.2-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | pypdf | source | sid | 6.21.0-1 | not yet assigned | Not reported | Not reported |
| Debian | pypdf | source | forky | 6.21.0-1 | not yet assigned | Not reported | Not reported |
| Debian | pypdf | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | pypdf | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | pypdf2 | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
Notes
[trixie] pypdf: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-pypdf]Affected
Source package: [pypdf]
Details (2)
3.4.1-1+deb12u1· all · bookwormAffected
dsa · pypdf · debian · bookworm; dsa · pypdf · debian · 12
3.4.1-1+deb12u1· all · bookwormAffected
dsa · pypdf · debian · bookworm; dsa · pypdf · debian · 12
- [python3-pypdf2]Affected
Source package: [pypdf2]
Details (2)
2.12.1-3+deb12u1· all · bookwormAffected
dsa · pypdf2 · debian · bookworm; dsa · pypdf2 · debian · 12
2.12.1-3+deb12u1· all · bookwormAffected
dsa · pypdf2 · debian · bookworm; dsa · pypdf2 · debian · 12
[Debian 13 (Trixie)]
- [python3-pypdf]Affected
Source package: [pypdf]
Details (2)
5.4.0-1· all · trixieAffected
dsa · pypdf · debian · 13
5.4.0-1· all · trixieAffected
dsa · pypdf · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-113790]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-113790]
- [https://security-tracker.debian.org/tracker/CVE-2026-113790]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-113790.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]