
CVE catalog
CVE-2026-22250
wlc vulnerabilities
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.15% · Oct 25, 2026
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | wlc | sid | 2.2.1-1 | fixed |
| Debian | wlc | forky | 2.2.1-1 | fixed |
| Debian | wlc | trixie | 1.15-1 | vulnerable |
| Debian | wlc | bookworm | 1.13-2 | vulnerable |
| Ubuntu | wlc | noble | Not reported | vulnerable |
| Ubuntu | wlc | noble | 1.13-2ubuntu0.1~esm1 | fixed |
| Ubuntu | wlc | pro | 1.13-2 | vulnerable |
| Ubuntu | wlc | pro | 1.13-2ubuntu0.1~esm1 | fixed |
| Ubuntu | wlc | 25.10 | 1.15-1 | vulnerable |
| Ubuntu | wlc | 25.10 | 1.15-2 | vulnerable |
| Ubuntu | wlc | 25.10 | 1.15-2ubuntu0.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | wlc | source | sid | 1.17.2-1 | not yet assigned | Not reported | [1125440] |
| Debian | wlc | source | forky | 1.17.2-1 | not yet assigned | Not reported | [1125440] |
| Debian | wlc | source | trixie | (unfixed) | not yet assigned | Not reported | [1125440] |
| Debian | wlc | source | bookworm | (unfixed) | not yet assigned | Not reported | [1125440] |
| Ubuntu | wlc | deb | noble | 1.13-2ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Ubuntu | wlc | deb | pro | 1.13-2ubuntu0.1~esm1 | Not reported | USN-7981-1 | Not reported |
| Ubuntu | wlc | deb | 25.10 | 1.15-2ubuntu0.1 | Not reported | USN-7981-1 | Not reported |
Notes
[trixie] wlc: Minor issue [bookworm] wlc: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [wlc]Affected
Details (2)
1.13-2· all · bookwormAffected
usn · wlc · debian · bookworm; usn · wlc · debian · 12
1.13-2· all · bookwormAffected
usn · wlc · debian · bookworm; usn · wlc · debian · 12
[Debian 13 (Trixie)]
- [wlc]Affected
Details (2)
1.15-1· all · trixieAffected
usn · wlc · debian · 13
1.15-1· all · trixieAffected
usn · wlc · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-22250]
- [https://osv.dev/vulnerability/USN-7981-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-22250]
- [https://ubuntu.com/security/notices/USN-7981-1]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Ubuntu Security Notices (USN)]