CVE catalog

CVE-2026-22610

angular.js: CVE-2026-22610

[CVE catalog]

Severity
High · CVSS 8CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.44% · Oct 25, 2026

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianangular.jssid1.8.3-3not affected
Debianangular.jstrixie1.8.3-3not affected
Debianangular.jsbookworm1.8.3-1+deb12u1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianangular.jssourcesidNot affectedunimportantNot reportedNot reported
Debianangular.jssourcetrixieNot affectedunimportantNot reportedNot reported
Debianangular.jssourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libjs-angularjs]Not affected

    Source package: [angular.js]

    Details (2)
    • 1.8.3-1+deb12u1 · all · bookworm

      Not affected

      dsa · angular.js · debian · bookworm

    • 1.8.3-1+deb12u1 · all · bookworm

      Not affected

      dsa · angular.js · debian · bookworm

Observed:

References