CVE catalog

CVE-2026-23535

wlc: CVE-2026-23535

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.39% · Oct 25, 2026

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianwlcsid2.2.1-1fixed
Debianwlcforky2.2.1-1fixed
Debianwlctrixie1.15-1vulnerable
Debianwlcbookworm1.13-2vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianwlcsourcesid1.17.2-1not yet assignedNot reported[1125755]
Debianwlcsourceforky1.17.2-1not yet assignedNot reported[1125755]
Debianwlcsourcetrixie(unfixed)not yet assignedNot reported[1125755]
Debianwlcsourcebookworm(unfixed)not yet assignedNot reported[1125755]

[Debian bug #1125755]

Notes

[trixie] wlc: Minor issue [bookworm] wlc: Minor issue

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [wlc]Affected
    Details (2)
    • 1.13-2 · all · bookworm

      Affected

      dsa · wlc · debian · bookworm; dsa · wlc · debian · 12

    • 1.13-2 · all · bookworm

      Affected

      dsa · wlc · debian · bookworm; dsa · wlc · debian · 12

[Debian 13 (Trixie)]

  • [wlc]Affected
    Details (2)
    • 1.15-1 · all · trixie

      Affected

      dsa · wlc · debian · 13

    • 1.15-1 · all · trixie

      Affected

      dsa · wlc · debian · 13

Observed:

References