
CVE catalog
CVE-2026-2391
node-qs: CVE-2026-2391
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.54% · Oct 25, 2026
### Summary The `arrayLimit` option in qs does not enforce limits for comma-separated values when `comma: true` is enabled, allowing attackers to cause denial-of-service via memory exhaustion. This is a bypass of the array limit enforcement, similar to the bracket notation bypass addressed in GHSA-6rw7-vpxm-498p (CVE-2025-15284). ### Details When the `comma` option is set to `true` (not the default, but configurable in applications), qs allows parsing comma-separated strings as arrays (e.g., `?param=a,b,c` becomes `['a', 'b', 'c']`). However, the limit check for `arrayLimit` (default: 20) and the optional throwOnLimitExceeded occur after the comma-handling logic in `parseArrayValue`, enabling a bypass. This permits creation of arbitrarily large arrays from a single parameter, leading to excessive memory allocation. **Vulnerable code** (lib/parse.js: lines ~40-50): ```js if (val && typeof val === 'string' && options.comma && val.indexOf(',') > -1) { return val.split(','); } if (options.throwOnLimitExceeded && currentArrayLength >= options.arrayLimit) { throw new RangeError('Array limit exceeded. Only ' + options.arrayLimit + ' element' + (options.arrayLimit === 1 ? '' : 's') + ' allowed in an array.'); } return val; ``` The `split(',')` returns the array immediately, skipping the subsequent limit check. Downstream merging via `utils.combine` does not prevent allocation, even if it marks overflows for sparse arrays.This discrepancy allows attackers to send a single parameter with millions of commas (e.g., `?param=,,,,,,,,...`), allocating massive arrays in memory without triggering limits. It bypasses the intent of `arrayLimit`, which is enforced correctly for indexed (`a[0]=`) and bracket (`a[]=`) notations (the latter fixed in v6.14.1 per GHSA-6rw7-vpxm-498p). ### PoC **Test 1 - Basic bypass:** ``` npm install qs ``` ```js const qs = require('qs'); const payload = 'a=' + ','.repeat(25); // 26 elements after split (bypasses arrayLimit: 5) const options = { comma: true, arrayLimit: 5, throwOnLimitExceeded: true }; try { const result = qs.parse(payload, options); console.log(result.a.length); // Outputs: 26 (bypass successful) } catch (e) { console.log('Limit enforced:', e.message); // Not thrown } ``` **Configuration:** - `comma: true` - `arrayLimit: 5` - `throwOnLimitExceeded: true` Expected: Throws "Array limit exceeded" error. Actual: Parses successfully, creating an array of length 26. ### Impact Denial of Service (DoS) via memory exhaustion.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-qs | sid | 6.16.0+ds+~6.15.1-1 | fixed |
| Debian | node-qs | forky | 6.16.0+ds+~6.15.1-1 | fixed |
| Debian | node-qs | trixie | 6.13.0+ds+~6.9.16-1 | vulnerable |
| Debian | node-qs | bookworm | 6.11.0+ds+~6.9.7-3 | vulnerable |
| Npm | qs | Not reported | 6.14.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-qs | source | sid | 6.15.0+ds+~6.15.0-1 | not yet assigned | Not reported | [1127940] |
| Debian | node-qs | source | forky | 6.15.0+ds+~6.15.0-1 | not yet assigned | Not reported | [1127940] |
| Debian | node-qs | source | trixie | (unfixed) | not yet assigned | Not reported | [1127940] |
| Debian | node-qs | source | bookworm | (unfixed) | not yet assigned | Not reported | [1127940] |
| Npm | qs | npm | Not reported | 6.14.2 | Not reported | GHSA-W7FW-MJWX-W883 | Not reported |
Notes
[trixie] node-qs: Minor issue [bookworm] node-qs: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-qs]Affected
Details (2)
6.11.0+ds+~6.9.7-3· all · bookwormAffected
dsa · node-qs · debian · bookworm; dsa · node-qs · debian · 12
6.11.0+ds+~6.9.7-3· all · bookwormAffected
dsa · node-qs · debian · bookworm; dsa · node-qs · debian · 12
[Debian 13 (Trixie)]
- [node-qs]Affected
Details (2)
6.13.0+ds+~6.9.16-1· all · trixieAffected
dsa · node-qs · debian · 13
6.13.0+ds+~6.9.16-1· all · trixieAffected
dsa · node-qs · debian · 13
Observed:
References
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-2391]
- [https://osv.dev/vulnerability/GHSA-w7fw-mjwx-w883]
- [https://security-tracker.debian.org/tracker/CVE-2026-2391]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2391.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2933.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]