
CVE catalog
CVE-2026-27601
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an a
- Severity
- High · CVSS 8.2
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.96% · Oct 25, 2026
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | underscore | sid | 1.13.8~dfsg+~1.13.0-1 | fixed |
| Debian | underscore | forky | 1.13.8~dfsg+~1.13.0-1 | fixed |
| Debian | underscore | trixie | 1.13.4~dfsg+~1.11.4-3 | vulnerable |
| Debian | underscore | bookworm | 1.13.4~dfsg+~1.11.4-3 | vulnerable |
| Npm | underscore | Not reported | 1.13.8 | fixed |
| Cpe | underscore | Not reported | Not reported | vulnerable |
| Npm | underscore | Not reported | 1.13.8 | fixed |
| Ubuntu | ruby-rails-assets-underscore | 18.04 | 1.8.3+dfsg-1 | vulnerable |
| Ubuntu | ruby-rails-assets-underscore | 20.04 | 1.8.3+dfsg-1 | vulnerable |
| Ubuntu | ruby-rails-assets-underscore | 22.04 | 1.8.3+dfsg-4 | vulnerable |
| Ubuntu | ruby-rails-assets-underscore | 24.04 | 1.8.3+dfsg-4 | vulnerable |
| Ubuntu | ruby-rails-assets-underscore | 24.04 | 1.8.3+dfsg-5 | vulnerable |
| Opensuse | python-nbclassic | tumbleweed | 1.3.3-1.1 | fixed |
| Opensuse | python-ipympl | tumbleweed | 0.9.7-17.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | underscore | source | sid | 1.13.8~dfsg+~1.13.0-1 | not yet assigned | Not reported | Not reported |
| Debian | underscore | source | forky | 1.13.8~dfsg+~1.13.0-1 | not yet assigned | Not reported | Not reported |
| Debian | underscore | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | underscore | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Npm | underscore | npm | Not reported | 1.13.8 | Not reported | GHSA-QPX9-HPMF-5GMW | Not reported |
| Npm | underscore | npm | Not reported | 1.13.8 | Not reported | Not reported | Not reported |
| Opensuse | python-nbclassic | rpm | tumbleweed | 1.3.3-1.1 | Not reported | OPENSUSE-SU-2026:10440-1 | Not reported |
| Opensuse | python-ipympl | rpm | tumbleweed | 0.9.7-17.1 | Not reported | OPENSUSE-SU-2026:10427-1 | Not reported |
Notes
[trixie] underscore: Minor issue [bookworm] underscore: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-underscore]Affected
Source package: [underscore]
Details (2)
1.13.4~dfsg+~1.11.4-3· all · bookwormAffected
nvd · underscore · debian · bookworm; nvd · underscore · debian · 12
1.13.4~dfsg+~1.11.4-3· all · bookwormAffected
nvd · underscore · debian · bookworm; nvd · underscore · debian · 12
- [node-underscore]Affected
Source package: [underscore]
Details (2)
1.13.4~dfsg+~1.11.4-3· all · bookwormAffected
nvd · underscore · debian · bookworm; nvd · underscore · debian · 12
1.13.4~dfsg+~1.11.4-3· all · bookwormAffected
nvd · underscore · debian · bookworm; nvd · underscore · debian · 12
[Debian 13 (Trixie)]
- [libjs-underscore]Affected
Source package: [underscore]
Details (2)
1.13.4~dfsg+~1.11.4-3· all · trixieAffected
nvd · underscore · debian · 13
1.13.4~dfsg+~1.11.4-3· all · trixieAffected
nvd · underscore · debian · 13
- [node-underscore]Affected
Source package: [underscore]
Details (2)
1.13.4~dfsg+~1.11.4-3· all · trixieAffected
nvd · underscore · debian · 13
1.13.4~dfsg+~1.11.4-3· all · trixieAffected
nvd · underscore · debian · 13
[openSUSE Tumbleweed]
- [jupyter-matplotlib]Unknown
Source package: [python-ipympl]
Details (1)
0.11.7-18.1· noarch · tumbleweedUnknown · Fixed:
0.9.7-17.1Version impact unknown
nvd · python-ipympl · opensuse · tumbleweed
- [jupyter-matplotlib-jupyterlab]Unknown
Source package: [python-ipympl]
Details (1)
0.11.7-18.1· noarch · tumbleweedUnknown · Fixed:
0.9.7-17.1Version impact unknown
nvd · python-ipympl · opensuse · tumbleweed
- [jupyter-nbclassic]Unknown
Source package: [python-nbclassic]
Details (1)
1.3.3-2.3· noarch · tumbleweedUnknown · Fixed:
1.3.3-1.1Version impact unknown
nvd · python-nbclassic · opensuse · tumbleweed
- [python313-ipympl]Unknown
Source package: [python-ipympl]
Details (1)
0.10.0-18.1· noarch · tumbleweedUnknown · Fixed:
0.9.7-17.1Version impact unknown
nvd · python-ipympl · opensuse · tumbleweed
- [python313-nbclassic]Unknown
Source package: [python-nbclassic]
Details (1)
1.3.3-2.3· noarch · tumbleweedUnknown · Fixed:
1.3.3-1.1Version impact unknown
nvd · python-nbclassic · opensuse · tumbleweed
- [python314-ipympl]Unknown
Source package: [python-ipympl]
Details (1)
0.10.0-18.1· noarch · tumbleweedUnknown · Fixed:
0.9.7-17.1Version impact unknown
nvd · python-ipympl · opensuse · tumbleweed
- [python314-nbclassic]Unknown
Source package: [python-nbclassic]
Details (1)
1.3.3-2.3· noarch · tumbleweedUnknown · Fixed:
1.3.3-1.1Version impact unknown
nvd · python-nbclassic · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_21448-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-27601]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-27601]
- [https://osv.dev/vulnerability/GHSA-qpx9-hpmf-5gmw]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-27601]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:10427-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2026:10440-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-27601]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27601.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1220.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]