CVE catalog

CVE-2026-27820

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zs

[CVE catalog]

Severity
High · CVSS 8.8CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.56% · Oct 25, 2026

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby3.1bookworm3.1.2-7+deb12u1vulnerable
Debianruby3.1bookworm-security3.1.2-7+deb12u1vulnerable
Cperuby3.1Not reportedNot reportedvulnerable
CpezlibNot reported3.0.1fixed
CpezlibNot reported3.1.2fixed
CpezlibNot reported3.2.3fixed
Alpineruby3.233.4.9-r0fixed
Alpineruby3.243.4.9-r0fixed
Ubunturuby2.3pro2.3.0-1vulnerable
Ubunturuby2.3pro2.3.0-2vulnerable
Ubunturuby2.3pro2.3.0-4ubuntu2vulnerable
Ubunturuby2.3pro2.3.0-4ubuntu3vulnerable
Ubunturuby2.3pro2.3.0-5ubuntu1vulnerable
Ubunturuby2.3pro2.3.1-2~16.04vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.2vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.4vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.5vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.6vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.7vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.9vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.10vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.11vulnerable
Ubunturuby2.3pro2.3.1-2~16.04.12vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.13vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.14vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.15vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm1vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm2vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm3vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm4vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm5vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm6vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm7vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm8vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm9vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm10vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm11vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm12vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm14vulnerable
Ubunturuby2.3pro2.3.1-2~ubuntu16.04.16+esm15fixed
CpezlibNot reported3.2.3fixed
Alpineruby3.213.3.13-r0fixed
Alpineruby3.223.4.9-r0fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby3.1sourcebookworm(unfixed)not yet assignedNot reportedNot reported
CpezlibcpeNot reported3.0.1Not reportedNot reportedNot reported
CpezlibcpeNot reported3.1.2Not reportedNot reportedNot reported
CpezlibcpeNot reported3.2.3Not reportedNot reportedNot reported
Alpinerubyapk3.233.4.9-r0Not reportedALPINE-CVE-2026-27820Not reported
Alpinerubyapk3.243.4.9-r0Not reportedALPINE-CVE-2026-27820Not reported
Ubunturuby2.3debpro2.3.1-2~ubuntu16.04.16+esm15Not reportedUSN-8556-1Not reported
CpezlibcpeNot reported3.2.3Not reportedNVD-CVE-2026-27820Not reported
Alpinerubyapk3.213.3.13-r0Not reportedALPINE-CVE-2026-27820Not reported
Alpinerubyapk3.223.4.9-r0Not reportedALPINE-CVE-2026-27820Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libruby3.1]Affected

    Source package: [ruby3.1]

    Details (4)
    • 3.1.2-7+deb12u1 · amd64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · amd64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

  • [ruby3.1]Affected
    Details (4)
    • 3.1.2-7+deb12u1 · amd64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · amd64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

  • [ruby3.1-dev]Affected

    Source package: [ruby3.1]

    Details (4)
    • 3.1.2-7+deb12u1 · amd64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · amd64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · arm64 · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

  • [ruby3.1-doc]Affected

    Source package: [ruby3.1]

    Details (4)
    • 3.1.2-7+deb12u1 · all · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · all · bookworm

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · all · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

    • 3.1.2-7+deb12u1 · all · bookworm-security

      Affected

      nvd · ruby3.1 · debian · bookworm; nvd · ruby3.1 · debian · 12

[Debian 13 (Trixie)]

  • [libruby3.3]Affected

    Source package: [ruby3.3]

    Details (2)
    • 3.3.8-2 · amd64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

    • 3.3.8-2 · arm64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

  • [ruby3.3]Affected
    Details (2)
    • 3.3.8-2 · amd64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

    • 3.3.8-2 · arm64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

  • [ruby3.3-dev]Affected

    Source package: [ruby3.3]

    Details (2)
    • 3.3.8-2 · amd64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

    • 3.3.8-2 · arm64 · trixie

      Affected

      nvd · ruby3.3 · debian · 13

  • [ruby3.3-doc]Affected

    Source package: [ruby3.3]

    Details (2)
    • 3.3.8-2 · all · trixie

      Affected

      nvd · ruby3.3 · debian · 13

    • 3.3.8-2 · all · trixie

      Affected

      nvd · ruby3.3 · debian · 13

Observed:

References