
CVE catalog
CVE-2026-31814
DEBIAN-CVE-2026-31814
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.47% · Oct 25, 2026
Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. From 0.13.0 to before 0.13.9, a specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. This vulnerability is fixed in 0.13.9.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | rust-yamux | 13 | 0.13.10+ds-1 | vulnerable |
| Debian | rust-yamux | 13 | 0.13.10+ds-2 | vulnerable |
| Debian | rust-yamux | 13 | 0.13.3-4 | vulnerable |
| Debian | rust-yamux | 13 | 0.13.7-1 | vulnerable |
| Debian | rust-yamux | 13 | 0.13.8-1 | vulnerable |
| Debian | rust-yamux | 13 | 0.13.9+ds-1 | vulnerable |
| Debian | rust-yamux | 14 | 0.13.3-4 | vulnerable |
| Debian | rust-yamux | 14 | 0.13.7-1 | vulnerable |
| Debian | rust-yamux | 14 | 0.13.8-1 | vulnerable |
| Debian | rust-yamux | 14 | 0.13.9+ds-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | rust-yamux | deb | 14 | 0.13.9+ds-1 | Not reported | DEBIAN-CVE-2026-31814 | Not reported |
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [librust-yamux-dev]Affected
Source package: [rust-yamux]
Details (2)
0.13.3-4· all · trixieAffected
pypi · rust-yamux · debian · 13
0.13.3-4· all · trixieAffected
pypi · rust-yamux · debian · 13
Observed: