CVE catalog

CVE-2026-32700

Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own.

[CVE catalog]

Severity
Medium · CVSS 6.8CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Published
Source
[NVD] · [CVE record]
EPSS
0.29% · Oct 25, 2026

Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the `reconfirmable` option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the `confirmation_token` and `unconfirmed_email` fields. The confirmation token is sent to an email the attacker controls, but the `unconfirmed_email` in the database points to a victim's email address. When the attacker uses the token, the victim's email is confirmed on the attacker's account. This is patched in Devise v5.0.3. Users should upgrade as soon as possible. As a workaround, applications can override a specific method from Devise models to force `unconfirmed_email` to be persisted when unchanged. Note that Mongoid does not seem to respect that `will_change!` should force the attribute to be persisted, even if it did not really change, so the user might have to implement a workaround similar to Devise by setting `changed_attributes["unconfirmed_email"] = nil` as well.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-devisebookworm4.8.1-1vulnerable
RubygemsdeviseNot reported5.0.3fixed
Cperuby-deviseNot reportedNot reportedvulnerable
Ubunturuby-devise16.043.5.1-1vulnerable
Ubunturuby-devise16.043.5.2-1vulnerable
Ubunturuby-devise16.043.5.2-2vulnerable
Ubunturuby-devise16.043.5.2-3vulnerable
Ubunturuby-devise16.043.5.6-2vulnerable
Ubunturuby-devise18.044.2.0-1vulnerable
Ubunturuby-devise18.044.3.0-1vulnerable
Ubunturuby-devise18.044.4.3-1vulnerable
Ubunturuby-devise20.044.5.0-3vulnerable
Ubunturuby-devise20.044.6.2-2vulnerable
Ubunturuby-devise20.044.7.1-2vulnerable
Ubunturuby-devise22.044.7.3-2vulnerable
Ubunturuby-devise24.044.8.1-1vulnerable
Ubunturuby-devise24.044.9.2-1vulnerable
Ubunturuby-devise24.044.9.3-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-devisesourcebookworm(unfixed)not yet assignedNot reportedNot reported
RubygemsdeviserubygemsNot reported5.0.3Not reportedNot reportedNot reported

Notes

[bookworm] ruby-devise: Minor issue

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-devise]Affected
    Details (2)
    • 4.8.1-1 · all · bookworm

      Affected

      nvd · ruby-devise · debian · bookworm; nvd · ruby-devise · debian · 12

    • 4.8.1-1 · all · bookworm

      Affected

      nvd · ruby-devise · debian · bookworm; nvd · ruby-devise · debian · 12

Observed:

References