CVE catalog

CVE-2026-32829

DEBIAN-CVE-2026-32829

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.62% · Oct 25, 2026

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianrust-lz4-flex130.11.3-1vulnerable
Debianrust-lz4-flex130.11.3-2vulnerable
Debianrust-lz4-flex130.13.0-1vulnerable
Debianrust-lz4-flex140.11.3-1vulnerable
Debianrust-lz4-flex140.11.3-2vulnerable
Debianrust-lz4-flex140.13.0-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianrust-lz4-flexdeb140.13.0-1Not reportedDEBIAN-CVE-2026-32829Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • Source package: [rust-lz4-flex]

    Details (2)
    • 0.11.3-1 · amd64 · trixie

      Affected

      pypi · rust-lz4-flex · debian · 13

    • 0.11.3-1 · arm64 · trixie

      Affected

      pypi · rust-lz4-flex · debian · 13

Observed:

References