
CVE catalog
CVE-2026-32935
phpseclib is a PHP secure communications library. Projects using versions 1.0.26 and below, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when usin
- Severity
- High · CVSS 8.2
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.39% · Oct 25, 2026
phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | phpseclib | sid | 1.0.30-1 | fixed |
| Debian | phpseclib | trixie | 1.0.23-6+deb13u3 | fixed |
| Debian | phpseclib | trixie-security | 1.0.23-6+deb13u1 | fixed |
| Debian | phpseclib | bookworm | 1.0.20-1+deb12u5 | fixed |
| Debian | phpseclib | bookworm-security | 1.0.20-1+deb12u3 | fixed |
| Debian | php-phpseclib | sid | 2.0.55-1 | fixed |
| Debian | php-phpseclib | forky | 2.0.55-1 | fixed |
| Debian | php-phpseclib | trixie | 2.0.48-3+deb13u3 | fixed |
| Debian | php-phpseclib | trixie-security | 2.0.48-3+deb13u1 | fixed |
| Debian | php-phpseclib | bookworm | 2.0.42-1+deb12u5 | fixed |
| Debian | php-phpseclib | bookworm-security | 2.0.42-1+deb12u3 | fixed |
| Debian | php-phpseclib3 | sid | 3.0.57-1 | fixed |
| Debian | php-phpseclib3 | forky | 3.0.57-1 | fixed |
| Debian | php-phpseclib3 | trixie | 3.0.43-2+deb13u3 | fixed |
| Debian | php-phpseclib3 | trixie-security | 3.0.43-2+deb13u1 | fixed |
| Debian | php-phpseclib3 | bookworm | 3.0.19-1+deb12u6 | fixed |
| Debian | php-phpseclib3 | bookworm-security | 3.0.19-1+deb12u4 | fixed |
| Composer | phpseclib/phpseclib | Not reported | 3.0.50 | fixed |
| Composer | phpseclib/phpseclib | Not reported | 2.0.52 | fixed |
| Composer | phpseclib/phpseclib | Not reported | 1.0.27 | fixed |
| Cpe | php-phpseclib | Not reported | Not reported | vulnerable |
| Ubuntu | phpseclib | noble | 1.0.23-1ubuntu0.1~esm1 | fixed |
| Ubuntu | php-seclib | noble | 1.0.23-1ubuntu0.1~esm1 | fixed |
| Ubuntu | php-phpseclib | noble | 2.0.47-1ubuntu0.1~esm1 | fixed |
| Ubuntu | php-phpseclib | pro | 2.0.48-3 | vulnerable |
| Ubuntu | php-phpseclib | pro | 2.0.49-1 | vulnerable |
| Ubuntu | php-phpseclib | pro | 2.0.51-1 | vulnerable |
| Ubuntu | php-phpseclib | pro | 2.0.51-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | phpseclib | source | sid | 1.0.27-1 | not yet assigned | Not reported | [1131484] |
| Debian | phpseclib | source | trixie | 1.0.23-6+deb13u1 | not yet assigned | Not reported | [1131484] |
| Debian | phpseclib | source | bookworm | 1.0.20-1+deb12u3 | not yet assigned | Not reported | [1131484] |
| Debian | php-phpseclib | source | sid | 2.0.52-1 | not yet assigned | Not reported | [1131483] |
| Debian | php-phpseclib | source | forky | 2.0.52-1 | not yet assigned | Not reported | [1131483] |
| Debian | php-phpseclib | source | trixie | 2.0.48-3+deb13u1 | not yet assigned | Not reported | [1131483] |
| Debian | php-phpseclib | source | bookworm | 2.0.42-1+deb12u3 | not yet assigned | Not reported | [1131483] |
| Debian | php-phpseclib3 | source | sid | 3.0.50-1 | not yet assigned | Not reported | [1131482] |
| Debian | php-phpseclib3 | source | forky | 3.0.50-1 | not yet assigned | Not reported | [1131482] |
| Debian | php-phpseclib3 | source | trixie | 3.0.43-2+deb13u1 | not yet assigned | Not reported | [1131482] |
| Debian | php-phpseclib3 | source | bookworm | 3.0.19-1+deb12u4 | not yet assigned | Not reported | [1131482] |
| Composer | phpseclib/phpseclib | composer | Not reported | 3.0.50 | Not reported | Not reported | Not reported |
| Composer | phpseclib/phpseclib | composer | Not reported | 2.0.52 | Not reported | Not reported | Not reported |
| Composer | phpseclib/phpseclib | composer | Not reported | 1.0.27 | Not reported | Not reported | Not reported |
| Ubuntu | phpseclib | deb | noble | 1.0.23-1ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Ubuntu | php-seclib | deb | noble | 1.0.23-1ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Ubuntu | php-phpseclib | deb | noble | 2.0.47-1ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Ubuntu | php-phpseclib | deb | pro | 2.0.51-1ubuntu0.1~esm1 | Not reported | USN-8830-1 | Not reported |
[Debian bug #1131484][Debian bug #1131483][Debian bug #1131482]
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://github.com/advisories/GHSA-94g3-g5v7-q4jg]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-32935]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-32935]
- [https://osv.dev/vulnerability/DSA-6185-1]
- [https://osv.dev/vulnerability/DSA-6186-1]
- [https://osv.dev/vulnerability/DSA-6187-1]
- [https://osv.dev/vulnerability/USN-8830-1]
- [https://security-tracker.debian.org/tracker/CVE-2026-32935]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32935.json]
- [https://ubuntu.com/security/notices/USN-8769-1]
- [https://ubuntu.com/security/notices/USN-8830-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1931.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]