
CVE catalog
CVE-2026-40046
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly val
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.38% · Oct 25, 2026
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | activemq | sid | 5.17.6+dfsg-2 | not affected |
| Debian | activemq | trixie | 5.17.6+dfsg-2 | not affected |
| Debian | activemq | bookworm | 5.17.2+dfsg-2+deb12u1 | not affected |
| Debian | activemq | bookworm-security | 5.17.2+dfsg-2+deb12u1 | not affected |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | activemq | source | sid | Not affected | unimportant | Not reported | Not reported |
| Debian | activemq | source | trixie | Not affected | unimportant | Not reported | Not reported |
| Debian | activemq | source | bookworm | Not affected | unimportant | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [activemq]Not affected
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookwormNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookworm-securityNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookworm-securityNot affected
nvd · activemq · debian · bookworm
- [libactivemq-java]Not affected
Source package: [activemq]
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookwormNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookworm-securityNot affected
nvd · activemq · debian · bookworm
5.17.2+dfsg-2+deb12u1· all · bookworm-securityNot affected
nvd · activemq · debian · bookworm
Observed:
References
- [https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt]
- [https://lists.apache.org/thread/zdntj5rcgjjzrpow84o339lzldy68zrg]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-40046]
- [https://security-tracker.debian.org/tracker/CVE-2026-40046]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40046.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1040.json]
- [https://www.cve.org/CVERecord?id=CVE-2025-66168]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [Red Hat security advisories and VEX]