
CVE catalog
CVE-2026-40110
Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat
- Severity
- High · CVSS 7.6
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.31% · Oct 25, 2026
Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat configuration value. Because re.match() only anchors at the start of the string and does not require a full match, a pattern intended to match only a trusted domain (e.g., trusted.example.com) will also match any origin that begins with that domain followed by additional characters (e.g., trusted.example.com.evil.com). An attacker who controls such a domain can bypass the CORS origin restriction and make cross-origin requests to the Jupyter Server API from an untrusted site. This issue has been fixed in version 2.18.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jupyter-server | sid | 2.20.0-3 | fixed |
| Debian | jupyter-server | forky | 2.20.0-3 | fixed |
| Debian | jupyter-server | trixie | 2.15.0-1 | vulnerable |
| Debian | jupyter-server | bookworm | 1.23.3-1 | vulnerable |
| Cpe | jupyter-server | Not reported | Not reported | vulnerable |
| Cpe | jupyter_server | Not reported | 2.18.0 | fixed |
| PyPI | jupyter-server | Not reported | 2.18.0 | fixed |
| PyPI | jupyter-server | Not reported | 2.18.0 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jupyter-server | source | sid | 2.20.0-1 | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | forky | 2.20.0-1 | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | trixie | (unfixed) | not yet assigned | Not reported | [1136022] |
| Debian | jupyter-server | source | bookworm | (unfixed) | not yet assigned | Not reported | [1136022] |
| Cpe | jupyter_server | cpe | Not reported | 2.18.0 | Not reported | Not reported | Not reported |
| PyPI | jupyter-server | PyPI | Not reported | 2.18.0 | Not reported | GHSA-24QX-W28J-9M6P | Not reported |
| PyPI | jupyter-server | PyPI | Not reported | 2.18.0 | Not reported | PYSEC-2026-2187 | Not reported |
Notes
[trixie] jupyter-server: Minor issue [bookworm] jupyter-server: Minor issue; unanchored allow_origin_pat re.match present, revisit with next update
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [jupyter-server]Affected
Details (2)
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
- [python3-jupyter-server]Affected
Source package: [jupyter-server]
Details (2)
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
1.23.3-1· all · bookwormAffected
nvd · jupyter-server · debian · bookworm; nvd · jupyter-server · debian · 12
[Debian 13 (Trixie)]
- [jupyter-server]Affected
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
- [python3-jupyter-server]Affected
Source package: [jupyter-server]
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
- [python-jupyter-server-doc]Affected
Source package: [jupyter-server]
Details (2)
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
2.15.0-1· all · trixieAffected
nvd · jupyter-server · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10710-1.json]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-40110]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-40110]
- [https://osv.dev/vulnerability/GHSA-24qx-w28j-9m6p]
- [https://security-tracker.debian.org/tracker/CVE-2026-40110]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40110.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]