
CVE catalog
CVE-2026-40682
XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor Versions Affected: before 2.5.9, before 3.0.0-M3 Description: The DictionaryEntryPersistor c
- Severity
- Critical · CVSS 9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.50% · Oct 25, 2026
XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor Versions Affected: before 2.5.9, before 3.0.0-M3 Description: The DictionaryEntryPersistor class initializes a static SAXParserFactory at class-load time without enabling FEATURE_SECURE_PROCESSING or disabling DTD processing. When create(InputStream, EntryInserter) is invoked, the only feature set on the XMLReader is namespace support — external entity resolution and DOCTYPE declarations remain fully enabled. An attacker who can supply a crafted dictionary file (e.g., a stop-word list or domain dictionary) containing a malicious DOCTYPE declaration can trigger local file disclosure via file:// entity references or server-side request forgery via http:// entity references during SAX parsing, before the application processes a single dictionary entry. This is inconsistent with the project's own XmlUtil.createSaxParser() helper, which correctly sets FEATURE_SECURE_PROCESSING and disallow-doctype-decl and is used by all other XML parsing paths in the codebase. The public Dictionary(InputStream) constructor delegates directly to this method and is the documented API for loading user-supplied dictionaries, making untrusted input a realistic scenario. Mitigation: 2.x users should upgrade to 2.5.9. 3.x users should upgrade to 3.0.0-M3. Users who cannot upgrade immediately should ensure that all dictionary files are sourced from trusted origins and should consider wrapping the Dictionary(InputStream) constructor with input validation that rejects any XML containing a DOCTYPE declaration before it reaches the parser.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | apache-opennlp | sid | 2.5.12-1 | fixed |
| Debian | apache-opennlp | forky | 2.5.12-1 | fixed |
| Debian | apache-opennlp | trixie | 2.5.3-1 | vulnerable |
| Debian | apache-opennlp | bookworm | 2.1.0-1 | vulnerable |
| Cpe | apache-opennlp | Not reported | Not reported | vulnerable |
| Cpe | opennlp | Not reported | 2.5.9 | fixed |
| Cpe | opennlp | Not reported | Not reported | unknown |
| Cpe | opennlp | Not reported | Not reported | unknown |
| Maven | org.apache.opennlp:opennlp-tools | Not reported | 1.9.5 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | apache-opennlp | source | sid | 2.5.9-1 | not yet assigned | Not reported | [1135782] |
| Debian | apache-opennlp | source | forky | 2.5.9-1 | not yet assigned | Not reported | [1135782] |
| Debian | apache-opennlp | source | trixie | (unfixed) | not yet assigned | Not reported | [1135782] |
| Debian | apache-opennlp | source | bookworm | (unfixed) | not yet assigned | Not reported | [1135782] |
| Cpe | opennlp | cpe | Not reported | 2.5.9 | Not reported | Not reported | Not reported |
| Maven | org.apache.opennlp:opennlp-tools | maven | Not reported | 1.9.5 | Not reported | GHSA-4V8G-86X5-3VRC | Not reported |
Notes
[trixie] apache-opennlp: Minor issue [bookworm] apache-opennlp: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libapache-opennlp-java]Affected
Source package: [apache-opennlp]
Details (2)
2.1.0-1· all · bookwormAffected
nvd · apache-opennlp · debian · bookworm; nvd · apache-opennlp · debian · 12
2.1.0-1· all · bookwormAffected
nvd · apache-opennlp · debian · bookworm; nvd · apache-opennlp · debian · 12
- [opennlp]Affected
Source package: [apache-opennlp]
Details (2)
2.1.0-1· all · bookwormAffected
nvd · apache-opennlp · debian · bookworm; nvd · apache-opennlp · debian · 12
2.1.0-1· all · bookwormAffected
nvd · apache-opennlp · debian · bookworm; nvd · apache-opennlp · debian · 12
[Debian 13 (Trixie)]
- [libapache-opennlp-java]Affected
Source package: [apache-opennlp]
Details (2)
2.5.3-1· all · trixieAffected
nvd · apache-opennlp · debian · 13
2.5.3-1· all · trixieAffected
nvd · apache-opennlp · debian · 13
- [opennlp]Affected
Source package: [apache-opennlp]
Details (2)
2.5.3-1· all · trixieAffected
nvd · apache-opennlp · debian · 13
2.5.3-1· all · trixieAffected
nvd · apache-opennlp · debian · 13
Observed:
References
- [http://www.openwall.com/lists/oss-security/2026/05/01/19]
- [https://access.redhat.com/security/cve/CVE-2026-40682]
- [https://bugzilla.redhat.com/show_bug.cgi?id=2466484]
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11281-1.json]
- [https://github.com/advisories/GHSA-4v8g-86x5-3vrc]
- [https://lists.apache.org/thread/r6jpt0qr9nj67gqhppqg7jxf8vsbo0w6]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-40682]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-40682]
- [https://security-tracker.debian.org/tracker/CVE-2026-40682]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40682.json]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]