
CVE catalog
CVE-2026-41149
DEBIAN-CVE-2026-41149
- Severity
- Medium · CVSS 5.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.40% · Oct 25, 2026
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and earlier, as well as 11.0.0-alpha.1 through 11.14.0, are vulnerable to HTML injection under the default configuration. Specifically, the classDef directive in Mermaid state diagrams permits DOM injection that escapes the SVG context. However, <script> tags are stripped, which prevents cross-site scripting (XSS). This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-mermaid | 14 | 8.11.0+ds+~cs29.13.22-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1.1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.8+~cs10.4.16-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+ds1+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2~bpo10+1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-3 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.1+ds+~cs26.20.25-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.3+ds+~cs29.13.19-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: