CVE catalog

CVE-2026-41163

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and

[CVE catalog]

Severity
High · CVSS 8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
Source
[NVD] · [CVE record]
EPSS
0.27% · Oct 25, 2026

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianbubblewrapsid0.13.1-1fixed
Debianbubblewrapforky0.13.1-1fixed
Debianbubblewraptrixie0.12.0-1~deb13u1fixed
Debianbubblewraptrixie-security0.12.0-1~deb13u1fixed
Debianbubblewrapbookworm0.8.0-2+deb12u1not affected
Debianbubblewrapbookworm-security0.8.0-2+deb12u1not affected
CpebubblewrapNot reportedNot reportednot affected
Ubuntububblewrap25.100.11.0-2vulnerable
Ubuntububblewrap25.100.11.0-2ubuntu0.1fixed
Ubuntububblewrap26.040.11.0-2vulnerable
Ubuntububblewrap26.040.11.0-2build1vulnerable
Ubuntububblewrap26.040.11.1-1vulnerable
Ubuntububblewrap26.040.11.1-1ubuntu0.1fixed
Opensusebubblewraptumbleweed0.11.2-1.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianbubblewrapsourcesid0.11.2-1not yet assignedNot reported[1134704]
Debianbubblewrapsourceforky0.11.2-1not yet assignedNot reported[1134704]
Debianbubblewrapsourcetrixie0.11.0-2+deb13u1not yet assignedNot reported[1134704]
DebianbubblewrapsourcebookwormNot affectedunimportantNot reported[1134704]
Ubuntububblewrapdeb25.100.11.0-2ubuntu0.1Not reportedUBUNTU-CVE-2026-41163Not reported
Ubuntububblewrapdeb26.040.11.1-1ubuntu0.1Not reportedUBUNTU-CVE-2026-41163Not reported
Opensusebubblewraprpmtumbleweed0.11.2-1.1Not reportedOPENSUSE-SU-2026:10671-1Not reported

[Debian bug #1134704]

OpenFactory catalog packages

[openSUSE Tumbleweed]

  • Source package: [bubblewrap]

    Details (1)
    • 0.11.2-1.3 · x86_64 · tumbleweed

      Unknown · Fixed: 0.11.2-1.1

      Version impact unknown

      nvd · bubblewrap · opensuse · tumbleweed

  • [bubblewrap]Fixed

    Source package: [bubblewrap]

    Details (1)
    • 0.11.2-1.3 · x86_64 · tumbleweed

      Fixed · Fixed: 0.11.2-1.1

      nvd · bubblewrap · opensuse · tumbleweed

[Debian 12 (Bookworm)]

  • [bubblewrap]Not affected
    Details (4)
    • 0.8.0-2+deb12u1 · amd64 · bookworm

      Not affected

      nvd · bubblewrap · debian · bookworm

    • 0.8.0-2+deb12u1 · arm64 · bookworm

      Not affected

      nvd · bubblewrap · debian · bookworm

    • 0.8.0-2+deb12u1 · amd64 · bookworm-security

      Not affected

      nvd · bubblewrap · debian · bookworm

    • 0.8.0-2+deb12u1 · arm64 · bookworm-security

      Not affected

      nvd · bubblewrap · debian · bookworm

[Debian 13 (Trixie)]

  • [bubblewrap]Fixed
    Details (4)
    • 0.11.0-2+deb13u1 · amd64 · trixie

      Fixed · Fixed: 0.11.0-2+deb13u1

      nvd · bubblewrap · debian · 13

    • 0.11.0-2+deb13u1 · arm64 · trixie

      Fixed · Fixed: 0.11.0-2+deb13u1

      nvd · bubblewrap · debian · 13

    • 0.12.0-1~deb13u1 · amd64 · trixie-security

      Fixed · Fixed: 0.11.0-2+deb13u1

      nvd · bubblewrap · debian · 13

    • 0.12.0-1~deb13u1 · arm64 · trixie-security

      Fixed · Fixed: 0.11.0-2+deb13u1

      nvd · bubblewrap · debian · 13

Observed:

References