
CVE catalog
CVE-2026-41691
Copilot said: i18nextify is a JavaScript library that adds i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 3.
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.31% · Oct 25, 2026
Copilot said: i18nextify is a JavaScript library that adds i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 3.0.5 interpolate the lng and ns values directly into the configured loadPath / addPath URL template without any encoding, validation, or path sanitisation. When an application exposes the language-code selection to user-controlled input (the default — i18next-browser-languagedetector reads ?lng= query params, cookies, localStorage, and request headers), an attacker can inject characters that change the structure of the outgoing request URL. This is a single URL-injection vulnerability. The attacker-controlled value is neutralised before it is used as part of an output URL string; the attack shape covers both path traversal and broader URL-structure injection — both are closed by the one interpolateUrl sanitisation fix. This issue has been fixed in version 3.0.5. If users cannot upgrade immediately, they can work around the issue by sanitising lng / ns before they reach i18next (strip .., /, \, ?, #, %, whitespace, and control characters; cap the length).
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-i18next-http-backend | sid | 2.4.1+ds-2 | vulnerable |
| Debian | node-i18next-http-backend | forky | 2.4.1+ds-2 | vulnerable |
| Debian | node-i18next-http-backend | trixie | 2.4.1+ds-2 | vulnerable |
| Debian | node-i18next-http-backend | bookworm | 2.1.1-1 | vulnerable |
| Cpe | i18next-http-backend | Not reported | 3.0.5 | fixed |
| Cpe | i18next-http-backend | Not reported | 3.0.5 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-i18next-http-backend | source | sid | (unfixed) | not yet assigned | Not reported | [1150648] |
| Debian | node-i18next-http-backend | source | forky | (unfixed) | not yet assigned | Not reported | [1150648] |
| Debian | node-i18next-http-backend | source | trixie | (unfixed) | not yet assigned | Not reported | [1150648] |
| Debian | node-i18next-http-backend | source | bookworm | (unfixed) | not yet assigned | Not reported | [1150648] |
| Cpe | i18next-http-backend | cpe | Not reported | 3.0.5 | Not reported | Not reported | Not reported |
| Cpe | i18next-http-backend | cpe | Not reported | 3.0.5 | Not reported | NVD-CVE-2026-41691 | Not reported |
Notes
[trixie] node-i18next-http-backend: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libjs-i18next-http-backend]Affected
Source package: [node-i18next-http-backend]
Details (2)
2.1.1-1· all · bookwormAffected
nvd · node-i18next-http-backend · debian · bookworm; nvd · node-i18next-http-backend · debian · 12
2.1.1-1· all · bookwormAffected
nvd · node-i18next-http-backend · debian · bookworm; nvd · node-i18next-http-backend · debian · 12
- [node-i18next-http-backend]Affected
Details (2)
2.1.1-1· all · bookwormAffected
nvd · node-i18next-http-backend · debian · bookworm; nvd · node-i18next-http-backend · debian · 12
2.1.1-1· all · bookwormAffected
nvd · node-i18next-http-backend · debian · bookworm; nvd · node-i18next-http-backend · debian · 12
[Debian 13 (Trixie)]
- [libjs-i18next-http-backend]Affected
Source package: [node-i18next-http-backend]
Details (2)
2.4.1+ds-2· all · trixieAffected
nvd · node-i18next-http-backend · debian · 13
2.4.1+ds-2· all · trixieAffected
nvd · node-i18next-http-backend · debian · 13
- [node-i18next-http-backend]Affected
Details (2)
2.4.1+ds-2· all · trixieAffected
nvd · node-i18next-http-backend · debian · 13
2.4.1+ds-2· all · trixieAffected
nvd · node-i18next-http-backend · debian · 13
Observed:
References
- [https://github.com/i18next/i18next-http-backend/commit/4cee84f229c637b9c182366d3156f726d407a621]
- [https://github.com/i18next/i18next-http-backend/security/advisories/GHSA-q89c-q3h5-w34g]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-41691]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-41691]
- [https://security-tracker.debian.org/tracker/CVE-2026-41691]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]