
CVE catalog
CVE-2026-42044
Axios is a promise based HTTP client for the browser and Node.js. From 1.0.0 to before 1.15.2, he Axios library is vulnerable to a Prototype Pollution "Gadget" attack that allows any Object.prototype
- Severity
- High · CVSS 7.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.61% · Oct 25, 2026
Axios is a promise based HTTP client for the browser and Node.js. From 1.0.0 to before 1.15.2, he Axios library is vulnerable to a Prototype Pollution "Gadget" attack that allows any Object.prototype pollution in the application's dependency tree to be escalated into surgical, invisible modification of all JSON API responses — including privilege escalation, balance manipulation, and authorization bypass. The default transformResponse function at lib/defaults/index.js:124 calls JSON.parse(data, this.parseReviver), where this is the merged config object. Because parseReviver is not present in Axios defaults, not validated by assertOptions, and not subject to any constraints, a polluted Object.prototype.parseReviver function is called for every key-value pair in every JSON response, allowing the attacker to selectively modify individual values while leaving the rest of the response intact. This vulnerability is fixed in 1.15.2.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-axios | sid | 1.20.0-1 | fixed |
| Debian | node-axios | forky | 1.20.0-1 | fixed |
| Debian | node-axios | trixie | 1.8.4+dfsg-1 | vulnerable |
| Debian | node-axios | bookworm | 1.2.1+dfsg-1+deb12u1 | vulnerable |
| Cpe | node-axios | Not reported | Not reported | vulnerable |
| Cpe | axios | Not reported | 1.15.1 | fixed |
| Ubuntu | node-axios | noble | 1.6.8+dfsg-2ubuntu0.1~esm1 | fixed |
| Cpe | axios | Not reported | 1.15.1 | fixed |
| Ubuntu | node-axios | 25.10 | 1.7.9+dfsg-1 | vulnerable |
| Ubuntu | node-axios | 25.10 | 1.8.4+dfsg-1 | vulnerable |
| Ubuntu | node-axios | 25.10 | 1.11.0+dfsg-1 | vulnerable |
| Ubuntu | node-axios | pro | 1.11.0+dfsg-1 | vulnerable |
| Ubuntu | node-axios | pro | 1.12.1+dfsg-1 | vulnerable |
| Ubuntu | node-axios | pro | 1.13.2+dfsg-1build1 | vulnerable |
| Ubuntu | node-axios | pro | 1.13.2+dfsg-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-axios | source | sid | 1.15.2-1 | not yet assigned | Not reported | [1134878] |
| Debian | node-axios | source | forky | 1.15.2-1 | not yet assigned | Not reported | [1134878] |
| Debian | node-axios | source | trixie | (unfixed) | not yet assigned | Not reported | [1134878] |
| Debian | node-axios | source | bookworm | (unfixed) | not yet assigned | Not reported | [1134878] |
| Cpe | axios | cpe | Not reported | 1.15.1 | Not reported | Not reported | Not reported |
| Ubuntu | node-axios | deb | noble | 1.6.8+dfsg-2ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
| Cpe | axios | cpe | Not reported | 1.15.1 | Not reported | NVD-CVE-2026-42044 | Not reported |
| Ubuntu | node-axios | deb | pro | 1.13.2+dfsg-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2026-42044 | Not reported |
Notes
[trixie] node-axios: Minor issue [bookworm] node-axios: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-axios]Affected
Details (2)
1.2.1+dfsg-1+deb12u1· all · bookwormAffected
nvd · node-axios · debian · bookworm; nvd · node-axios · debian · 12
1.2.1+dfsg-1+deb12u1· all · bookwormAffected
nvd · node-axios · debian · bookworm; nvd · node-axios · debian · 12
[Debian 13 (Trixie)]
- [node-axios]Affected
Details (2)
1.8.4+dfsg-1· all · trixieAffected
nvd · node-axios · debian · 13
1.8.4+dfsg-1· all · trixieAffected
nvd · node-axios · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-42044]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-42044]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-42044]
- [https://security-tracker.debian.org/tracker/CVE-2026-42044]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42044.json]
- [https://ubuntu.com/security/notices/USN-8638-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1450.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]