
CVE catalog
CVE-2026-42268
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused b
- Severity
- High · CVSS 8.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.40% · Oct 25, 2026
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | modsecurity | sid | 3.0.16-1 | fixed |
| Debian | modsecurity | forky | 3.0.16-1 | fixed |
| Debian | modsecurity | trixie | 3.0.14-1+deb13u1 | fixed |
| Debian | modsecurity | bookworm | 3.0.9-1+deb12u2 | fixed |
| Cpe | modsecurity | Not reported | 3.0.15 | fixed |
| Cpe | modsecurity | Not reported | 3.0.15 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | modsecurity | source | sid | 3.0.15-1 | not yet assigned | Not reported | Not reported |
| Debian | modsecurity | source | forky | 3.0.15-1 | not yet assigned | Not reported | Not reported |
| Debian | modsecurity | source | trixie | 3.0.14-1+deb13u1 | not yet assigned | Not reported | Not reported |
| Debian | modsecurity | source | bookworm | 3.0.9-1+deb12u2 | not yet assigned | Not reported | Not reported |
| Cpe | modsecurity | cpe | Not reported | 3.0.15 | Not reported | Not reported | Not reported |
| Cpe | modsecurity | cpe | Not reported | 3.0.15 | Not reported | NVD-CVE-2026-42268 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libmodsecurity3]Fixed
Source package: [modsecurity]
Details (2)
3.0.9-1+deb12u2· amd64 · bookwormFixed · Fixed:
3.0.9-1+deb12u2nvd · modsecurity · debian · bookworm; nvd · modsecurity · debian · 12
3.0.9-1+deb12u2· arm64 · bookwormFixed · Fixed:
3.0.9-1+deb12u2nvd · modsecurity · debian · bookworm; nvd · modsecurity · debian · 12
- [libmodsecurity-dev]Fixed
Source package: [modsecurity]
Details (2)
3.0.9-1+deb12u2· amd64 · bookwormFixed · Fixed:
3.0.9-1+deb12u2nvd · modsecurity · debian · bookworm; nvd · modsecurity · debian · 12
3.0.9-1+deb12u2· arm64 · bookwormFixed · Fixed:
3.0.9-1+deb12u2nvd · modsecurity · debian · bookworm; nvd · modsecurity · debian · 12
[Debian 13 (Trixie)]
- [libmodsecurity3t64]Fixed
Source package: [modsecurity]
Details (2)
3.0.14-1+deb13u1· amd64 · trixieFixed · Fixed:
3.0.14-1+deb13u1nvd · modsecurity · debian · 13
3.0.14-1+deb13u1· arm64 · trixieFixed · Fixed:
3.0.14-1+deb13u1nvd · modsecurity · debian · 13
- [libmodsecurity-dev]Fixed
Source package: [modsecurity]
Details (2)
3.0.14-1+deb13u1· amd64 · trixieFixed · Fixed:
3.0.14-1+deb13u1nvd · modsecurity · debian · 13
3.0.14-1+deb13u1· arm64 · trixieFixed · Fixed:
3.0.14-1+deb13u1nvd · modsecurity · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10732-1.json]
- [https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vwr3-7x7g-7p9w]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-42268]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-42268]
- [https://security-tracker.debian.org/tracker/CVE-2026-42268]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42268.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1308.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]