
CVE catalog
CVE-2026-42357
Incorrect Authorization vulnerability allows users to access workflow instance information belonging to projects they do not have permission to access. This issue affects Apache DolphinScheduler vers
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.31% · Oct 27, 2026
Incorrect Authorization vulnerability allows users to access workflow instance information belonging to projects they do not have permission to access. This issue affects Apache DolphinScheduler versions prior to 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes this issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Cpe | dolphinscheduler | Not reported | 3.4.2 | fixed |
| Cpe | dolphinscheduler | Not reported | 3.4.2 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Cpe | dolphinscheduler | cpe | Not reported | 3.4.2 | Not reported | Not reported | Not reported |
| Cpe | dolphinscheduler | cpe | Not reported | 3.4.2 | Not reported | NVD-CVE-2026-42357 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: