
CVE catalog
CVE-2026-42587
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpContentDecompressor accepts a maxAllocation parameter to limit decompression buffer s
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.99% · Oct 25, 2026
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpContentDecompressor accepts a maxAllocation parameter to limit decompression buffer size and prevent decompression bomb attacks. This limit is correctly enforced for gzip and deflate encodings via ZlibDecoder, but is silently ignored when the content encoding is br (Brotli), zstd, or snappy. An attacker can bypass the configured decompression limit by sending a compressed payload with Content-Encoding: br instead of Content-Encoding: gzip, causing unbounded memory allocation and out-of-memory denial of service. The same vulnerability exists in DelegatingDecompressorFrameListener for HTTP/2 connections. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | vulnerable |
| Debian | netty | forky | 1:4.1.48-16 | vulnerable |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | vulnerable |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | vulnerable |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | vulnerable |
| Cpe | netty | Not reported | Not reported | vulnerable |
| Cpe | netty | Not reported | 4.1.133 | fixed |
| Cpe | netty | Not reported | 4.2.13 | fixed |
| Cpe | netty | Not reported | 4.2.13 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | (unfixed) | not yet assigned | Not reported | [1139914] |
| Debian | netty | source | forky | (unfixed) | not yet assigned | Not reported | [1139914] |
| Debian | netty | source | trixie | (unfixed) | not yet assigned | Not reported | [1139914] |
| Debian | netty | source | bookworm | (unfixed) | not yet assigned | Not reported | [1139914] |
| Cpe | netty | cpe | Not reported | 4.1.133 | Not reported | Not reported | Not reported |
| Cpe | netty | cpe | Not reported | 4.2.13 | Not reported | Not reported | Not reported |
| Cpe | netty | cpe | Not reported | 4.2.13 | Not reported | NVD-CVE-2026-42587 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookwormAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
1:4.1.48-7+deb12u2· all · bookworm-securityAffected
nvd · netty · debian · bookworm; nvd · netty · debian · 12
[Debian 13 (Trixie)]
- [libnetty-java]Affected
Source package: [netty]
Details (4)
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixieAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
1:4.1.48-10+deb13u1· all · trixie-securityAffected
nvd · netty · debian · 13
Observed:
References
- [https://access.redhat.com/errata/RHSA-2026:23808]
- [https://access.redhat.com/errata/RHSA-2026:24502]
- [https://access.redhat.com/errata/RHSA-2026:25123]
- [https://access.redhat.com/errata/RHSA-2026:28010]
- [https://access.redhat.com/errata/RHSA-2026:34608]
- [https://access.redhat.com/errata/RHSA-2026:36820]
- [https://access.redhat.com/errata/RHSA-2026:37390]
- [https://access.redhat.com/errata/RHSA-2026:41951]
- [https://access.redhat.com/errata/RHSA-2026:42644]
- [https://access.redhat.com/errata/RHSA-2026:49700]
- [https://access.redhat.com/errata/RHSA-2026:49701]
- [https://access.redhat.com/errata/RHSA-2026:50085]
- [https://access.redhat.com/errata/RHSA-2026:53644]
- [https://access.redhat.com/errata/RHSA-2026:53645]
- [https://access.redhat.com/errata/RHSA-2026:53646]
- [https://access.redhat.com/errata/RHSA-2026:54435]
- [https://access.redhat.com/errata/RHSA-2026:65126]
- [https://access.redhat.com/errata/RHSA-2026:66488]
- [https://access.redhat.com/errata/RHSA-2026:66545]
- [https://access.redhat.com/security/cve/CVE-2026-42587]
- [https://bugzilla.redhat.com/show_bug.cgi?id=2477220]
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10795-1.json]
- [https://github.com/netty/netty/security/advisories/GHSA-f6hv-jmp6-3vwv]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-42587]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-42587]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-42587]
- [https://security-tracker.debian.org/tracker/CVE-2026-42587]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42587.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2434.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]