
CVE catalog
CVE-2026-44167
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a byp
- Severity
- High · CVSS 8.2
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.20% · Oct 25, 2026
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | phpseclib | sid | 1.0.30-1 | fixed |
| Debian | phpseclib | trixie | 1.0.23-6+deb13u3 | fixed |
| Debian | phpseclib | trixie-security | 1.0.23-6+deb13u1 | vulnerable |
| Debian | phpseclib | bookworm | 1.0.20-1+deb12u5 | fixed |
| Debian | phpseclib | bookworm-security | 1.0.20-1+deb12u3 | vulnerable |
| Debian | php-phpseclib | sid | 2.0.55-1 | fixed |
| Debian | php-phpseclib | forky | 2.0.55-1 | fixed |
| Debian | php-phpseclib | trixie | 2.0.48-3+deb13u3 | fixed |
| Debian | php-phpseclib | trixie-security | 2.0.48-3+deb13u1 | vulnerable |
| Debian | php-phpseclib | bookworm | 2.0.42-1+deb12u5 | fixed |
| Debian | php-phpseclib | bookworm-security | 2.0.42-1+deb12u3 | vulnerable |
| Debian | php-phpseclib3 | sid | 3.0.57-1 | fixed |
| Debian | php-phpseclib3 | forky | 3.0.57-1 | fixed |
| Debian | php-phpseclib3 | trixie | 3.0.43-2+deb13u3 | fixed |
| Debian | php-phpseclib3 | trixie-security | 3.0.43-2+deb13u1 | vulnerable |
| Debian | php-phpseclib3 | bookworm | 3.0.19-1+deb12u6 | fixed |
| Debian | php-phpseclib3 | bookworm-security | 3.0.19-1+deb12u4 | vulnerable |
| Ubuntu | php-phpseclib | noble | 2.0.47-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | phpseclib | source | sid | 1.0.29-1 | not yet assigned | Not reported | Not reported |
| Debian | phpseclib | source | trixie | 1.0.23-6+deb13u3 | not yet assigned | Not reported | Not reported |
| Debian | phpseclib | source | bookworm | 1.0.20-1+deb12u5 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib | source | sid | 2.0.54-1 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib | source | forky | 2.0.54-1 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib | source | trixie | 2.0.48-3+deb13u3 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib | source | bookworm | 2.0.42-1+deb12u5 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib3 | source | sid | 3.0.52-1 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib3 | source | forky | 3.0.52-1 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib3 | source | trixie | 3.0.43-2+deb13u3 | not yet assigned | Not reported | Not reported |
| Debian | php-phpseclib3 | source | bookworm | 3.0.19-1+deb12u6 | not yet assigned | Not reported | Not reported |
| Ubuntu | php-phpseclib | deb | noble | 2.0.47-1ubuntu0.1~esm1 | Not reported | Not reported | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-44167]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-44167]
- [https://security-tracker.debian.org/tracker/CVE-2026-44167]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44167.json]
- [https://ubuntu.com/security/notices/USN-8830-1]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]