CVE catalog

CVE-2026-44587

CarrierWave is a framework to upload files from Ruby applications. In versions prior to 2.2.7 and 3.1.3, the content_type_denylist check fails to escape regex metacharacters in string entries, causing

[CVE catalog]

Severity
Medium · CVSS 4.7CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
Published
Source
[NVD] · [CVE record]
EPSS
0.22% · Oct 25, 2026

CarrierWave is a framework to upload files from Ruby applications. In versions prior to 2.2.7 and 3.1.3, the content_type_denylist check fails to escape regex metacharacters in string entries, causing the denylist to silently not match the content types it is intended to block. In lib/carrierwave/uploader/content_type_denylist.rb:57, denylist entries are interpolated directly into a regex without Regexp.quote or anchoring, so an entry such as image/svg+xml becomes the pattern /image\/svg+xml/, in which + is treated as a quantifier rather than a literal character and therefore never matches the real MIME type image/svg+xml. This is inconsistent with the allowlist implementation, which correctly applies both Regexp.quote and a \A anchor. Other content types containing regex metacharacters, such as application/xhtml+xml, are affected as well. As a result, any application that relies on content_type_denylist to block image/svg+xml, most commonly to prevent stored XSS, is silently unprotected. An attacker can upload an SVG file containing arbitrary JavaScript; if the application serves that SVG inline from its own origin, the script executes in the victim's browser, resulting in stored XSS. This issue has been fixed in versions 2.2.7 and 3.1.3.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-carrierwavebookworm1.3.2-2vulnerable
Cperuby-carrierwaveNot reportedNot reportedvulnerable
CpecarrierwaveNot reported2.2.7fixed
CpecarrierwaveNot reported3.1.3fixed
Ubunturuby-carrierwave16.040.10.0+gh-1vulnerable
Ubunturuby-carrierwave16.040.10.0+gh-2vulnerable
Ubunturuby-carrierwavepro1.3.2-2vulnerable
Ubunturuby-carrierwavepro1.3.2-2ubuntu0.24.04.1~esm1vulnerable
CpecarrierwaveNot reported3.1.3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-carrierwavesourcebookworm(unfixed)not yet assignedNot reportedNot reported
CpecarrierwavecpeNot reported2.2.7Not reportedNot reportedNot reported
CpecarrierwavecpeNot reported3.1.3Not reportedNot reportedNot reported
CpecarrierwavecpeNot reported3.1.3Not reportedNVD-CVE-2026-44587Not reported

Notes

[bookworm] ruby-carrierwave: Minor issue

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.3.2-2 · all · bookworm

      Affected

      nvd · ruby-carrierwave · debian · bookworm; nvd · ruby-carrierwave · debian · 12

    • 1.3.2-2 · all · bookworm

      Affected

      nvd · ruby-carrierwave · debian · bookworm; nvd · ruby-carrierwave · debian · 12

Observed:

References