
CVE catalog
CVE-2026-45505
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Non-parenthesized discovery wrappe
- Severity
- High · CVSS 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.60% · Oct 25, 2026
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Non-parenthesized discovery wrappers such as `masterslave:vm://...,...` and `static:vm://...` incorrectly pass validation allowing bypass of fix in CVE-2026-34197. Original description from CVE-2026-34197. Apache ActiveMQ exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery UR that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | activemq | sid | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | trixie | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | bookworm | 5.17.2+dfsg-2+deb12u1 | vulnerable |
| Debian | activemq | bookworm-security | 5.17.2+dfsg-2+deb12u1 | vulnerable |
| Cpe | activemq | Not reported | Not reported | vulnerable |
| Cpe | activemq | Not reported | 5.19.7 | fixed |
| Cpe | activemq | Not reported | 6.2.6 | fixed |
| Cpe | activemq_broker | Not reported | 5.19.7 | fixed |
| Cpe | activemq_broker | Not reported | 6.2.6 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | activemq | source | sid | (unfixed) | not yet assigned | Not reported | [1141385] |
| Debian | activemq | source | trixie | (unfixed) | not yet assigned | Not reported | [1141385] |
| Debian | activemq | source | bookworm | (unfixed) | not yet assigned | Not reported | [1141385] |
| Cpe | activemq | cpe | Not reported | 5.19.7 | Not reported | Not reported | Not reported |
| Cpe | activemq | cpe | Not reported | 6.2.6 | Not reported | Not reported | Not reported |
| Cpe | activemq_broker | cpe | Not reported | 5.19.7 | Not reported | Not reported | Not reported |
| Cpe | activemq_broker | cpe | Not reported | 6.2.6 | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [activemq]Affected
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
- [libactivemq-java]Affected
Source package: [activemq]
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
[Debian 13 (Trixie)]
- [activemq]Affected
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
- [libactivemq-java]Affected
Source package: [activemq]
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-45505]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-45505]
- [https://security-tracker.debian.org/tracker/CVE-2026-45505]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45505.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1741.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]