
CVE catalog
CVE-2026-46531
cacti: CVE-2026-46531
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.20% · Oct 25, 2026
Cacti is an open source performance and fault management framework. From version 1.2.27 to before version 1.2.31, Cacti contains an authenticated stored second-order SQL injection in the automation tree rule item handler. A user holding the Automation realm (default General Administration role) can persist an arbitrary SQL fragment in the automation_tree_rule_items.field column. The fragment is later concatenated directly into a SELECT ... AS source FROM ... clause in lib/api_automation.php :: create_all_header_nodes() and executed when an administrator triggers automation via the standard graphs.php?action=actions&drp_action=8 ("Apply Automation Rules") bulk action. The result of the injected SELECT is written into graph_tree_items.title and rendered in the Cacti tree UI, providing a direct exfiltration channe. This issue has been patched in version 1.2.31.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | cacti | sid | 1.2.31+ds1-4 | fixed |
| Debian | cacti | forky | 1.2.31+ds1-4 | fixed |
| Debian | cacti | trixie | 1.2.30+ds1-1 | vulnerable |
| Debian | cacti | bookworm | 1.2.24+ds1-1+deb12u5 | vulnerable |
| Debian | cacti | bookworm-security | 1.2.24+ds1-1+deb12u5 | vulnerable |
| Ubuntu | cacti | pro | 1.2.16+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm1 | vulnerable |
| Ubuntu | cacti | pro | 1.2.19+ds1-2ubuntu1.1+esm2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.25+ds1-2 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1 | vulnerable |
| Ubuntu | cacti | 24.04 | 1.2.26+ds1-1ubuntu0.1 | vulnerable |
| Ubuntu | cacti | 26.10 | 1.2.30+ds1-1ubuntu2 | vulnerable |
| Ubuntu | cacti | 26.10 | 1.2.30+ds1-1ubuntu3 | vulnerable |
| Ubuntu | cacti | 26.10 | 1.2.31+ds1-3ubuntu2 | vulnerable |
| Ubuntu | cacti | 26.04 | 1.2.30+ds1-1ubuntu1 | vulnerable |
| Ubuntu | cacti | 26.04 | 1.2.30+ds1-1ubuntu2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | cacti | source | sid | 1.2.31+ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | forky | 1.2.31+ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | cacti | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [cacti]Affected
Details (4)
1.2.24+ds1-1+deb12u5· all · bookwormAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookwormAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
1.2.24+ds1-1+deb12u5· all · bookworm-securityAffected
dsa · cacti · debian · bookworm; dsa · cacti · debian · 12
[Debian 13 (Trixie)]
- [cacti]Affected
Details (2)
1.2.30+ds1-1· all · trixieAffected
dsa · cacti · debian · 13
1.2.30+ds1-1· all · trixieAffected
dsa · cacti · debian · 13
Observed: