CVE catalog

CVE-2026-46587

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to

[CVE catalog]

Severity
High · CVSS 7.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Published
Source
[NVD] · [CVE record]
EPSS
0.69% · Oct 25, 2026

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
CpecamelNot reported4.14.8fixed
CpecamelNot reported4.18.3fixed
CpecamelNot reported4.21.0fixed
Mavenorg.apache.camel:camel-couchbaseNot reported4.21.0fixed
CpecamelNot reported4.21.0fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
CpecamelcpeNot reported4.14.8Not reportedNot reportedNot reported
CpecamelcpeNot reported4.18.3Not reportedNot reportedNot reported
CpecamelcpeNot reported4.21.0Not reportedNot reportedNot reported
Mavenorg.apache.camel:camel-couchbasemavenNot reported4.21.0Not reportedGHSA-46JF-C9VX-HH79Not reported
CpecamelcpeNot reported4.21.0Not reportedNVD-CVE-2026-46587Not reported

OpenFactory catalog packages

No matching packages in this catalog.

Observed:

References