
CVE catalog
CVE-2026-46607
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, glances/outdated.py uses pickle.load() to read a version-check cache file stored at a predictable, world-accessible pat
- Severity
- High · CVSS 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.36% · Oct 25, 2026
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, glances/outdated.py uses pickle.load() to read a version-check cache file stored at a predictable, world-accessible path (~/.cache/glances/glances-version.db or $XDG_CACHE_HOME/glances/glances-version.db). No integrity check, signature verification, or format validation is performed before deserialization. An attacker with write access to that path — through any of several realistic local or container-level scenarios — can plant a malicious pickle file and achieve arbitrary code execution as the OS user running Glances the next time it starts with version checking enabled (the default). This vulnerability is fixed in 4.5.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | glances | sid | 4.5.8+dfsg-1 | fixed |
| Debian | glances | forky | 4.5.8+dfsg-1 | fixed |
| Debian | glances | trixie | 4.3.1+dfsg-1 | vulnerable |
| Debian | glances | bookworm | 3.3.1.1+dfsg-1 | vulnerable |
| Cpe | glances | Not reported | Not reported | vulnerable |
| PyPI | glances | Not reported | 4.5.5 | fixed |
| Ubuntu | glances | pro | 3.1.0-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.1-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.3-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.3-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.1.5-1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.2.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.2.4.2+dfsg-1 | vulnerable |
| Ubuntu | glances | 24.04 | 3.4.0.3+dfsg-1 | vulnerable |
| Ubuntu | glances | 25.10 | 4.3.0.8+dfsg-1 | vulnerable |
| Ubuntu | glances | 25.10 | 4.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 26.04 | 4.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 26.04 | 4.3.3+dfsg-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | glances | source | sid | 4.5.5+dfsg-1 | not yet assigned | Not reported | Not reported |
| Debian | glances | source | forky | 4.5.5+dfsg-1 | not yet assigned | Not reported | Not reported |
| Debian | glances | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | glances | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| PyPI | glances | PyPI | Not reported | 4.5.5 | Not reported | PYSEC-2026-2496 | Not reported |
Notes
[trixie] glances: Minor issue [bookworm] glances: Minor issue; outdated.py _load_cache pickle.load of cached glances-version.db present; requires local cache write
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [glances]Affected
Details (2)
3.3.1.1+dfsg-1· all · bookwormAffected
nvd · glances · debian · bookworm; nvd · glances · debian · 12
3.3.1.1+dfsg-1· all · bookwormAffected
nvd · glances · debian · bookworm; nvd · glances · debian · 12
- [glances-doc]Affected
Source package: [glances]
Details (2)
3.3.1.1+dfsg-1· all · bookwormAffected
nvd · glances · debian · bookworm; nvd · glances · debian · 12
3.3.1.1+dfsg-1· all · bookwormAffected
nvd · glances · debian · bookworm; nvd · glances · debian · 12
[Debian 13 (Trixie)]
- [glances]Affected
Details (2)
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
- [glances-doc]Affected
Source package: [glances]
Details (2)
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11122-1.json]
- [https://github.com/nicolargo/glances/releases/tag/v4.5.5]
- [https://github.com/nicolargo/glances/security/advisories/GHSA-9837-48hr-q32j]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-46607]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-46607]
- [https://osv.dev/vulnerability/PYSEC-2026-2496]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-46607]
- [https://security-tracker.debian.org/tracker/CVE-2026-46607]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-46607.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]