
CVE catalog
CVE-2026-46608
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, the Glances XML-RPC server (glances -s) introduced a configurable CORS origin list in version 4.5.3 as a mitigation for
- Severity
- High · CVSS 7.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.40% · Oct 27, 2026
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.5, the Glances XML-RPC server (glances -s) introduced a configurable CORS origin list in version 4.5.3 as a mitigation for CVE-2026-33533. However, the implementation silently falls back to Access-Control-Allow-Origin: * whenever cors_origins contains more than one entry. An operator who configures an explicit two-entry allowlist (e.g. two internal dashboard origins) intending to restrict browser access instead receives the unrestricted wildcard. A malicious web page served from any origin can issue a CORS simple request to /RPC2 and read the full system monitoring dataset without the victim's knowledge. This vulnerability is fixed in 4.5.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | glances | sid | 4.5.8+dfsg-1 | fixed |
| Debian | glances | forky | 4.5.8+dfsg-1 | fixed |
| Debian | glances | trixie | 4.3.1+dfsg-1 | vulnerable |
| Debian | glances | bookworm | 3.3.1.1+dfsg-1 | not affected |
| PyPI | glances | Not reported | 4.5.5 | fixed |
| Ubuntu | glances | pro | 3.1.0-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.1-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.3-1 | vulnerable |
| Ubuntu | glances | pro | 3.1.3-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.1.5-1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.2.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 22.04 | 3.2.4.2+dfsg-1 | vulnerable |
| Ubuntu | glances | 24.04 | 3.4.0.3+dfsg-1 | vulnerable |
| Ubuntu | glances | 25.10 | 4.3.0.8+dfsg-1 | vulnerable |
| Ubuntu | glances | 25.10 | 4.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 26.04 | 4.3.1+dfsg-1 | vulnerable |
| Ubuntu | glances | 26.04 | 4.3.3+dfsg-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | glances | source | sid | 4.5.5+dfsg-1 | not yet assigned | Not reported | Not reported |
| Debian | glances | source | forky | 4.5.5+dfsg-1 | not yet assigned | Not reported | Not reported |
| Debian | glances | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | glances | source | bookworm | Not affected | unimportant | Not reported | Not reported |
| PyPI | glances | PyPI | Not reported | 4.5.5 | Not reported | PYSEC-2026-2495 | Not reported |
Notes
[trixie] glances: Minor issue
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [glances]Affected
Details (2)
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
- [glances-doc]Affected
Source package: [glances]
Details (2)
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
4.3.1+dfsg-1· all · trixieAffected
nvd · glances · debian · 13
[Debian 12 (Bookworm)]
- [glances]Not affected
Details (2)
3.3.1.1+dfsg-1· all · bookwormNot affected
nvd · glances · debian · bookworm
3.3.1.1+dfsg-1· all · bookwormNot affected
nvd · glances · debian · bookworm
- [glances-doc]Not affected
Source package: [glances]
Details (2)
3.3.1.1+dfsg-1· all · bookwormNot affected
nvd · glances · debian · bookworm
3.3.1.1+dfsg-1· all · bookwormNot affected
nvd · glances · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11122-1.json]
- [https://github.com/nicolargo/glances/releases/tag/v4.5.5]
- [https://github.com/nicolargo/glances/security/advisories/GHSA-87qc-fj39-wccr]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-46608]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-46608]
- [https://osv.dev/vulnerability/PYSEC-2026-2495]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-46608]
- [https://security-tracker.debian.org/tracker/CVE-2026-46608]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-46608.json]
[Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]