
CVE catalog
CVE-2026-47101
LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit. When generating a key, the allowed_routes field is stored witho
- Severity
- High · CVSS 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.19% · Oct 25, 2026
A flaw was found in LiteLLM. An authenticated internal user can exploit this vulnerability by creating API keys that grant access to routes beyond their assigned role. This occurs because the system fails to verify if the specified allowed_routes for the API key align with the user's actual permissions. Consequently, a malicious internal user can achieve full privilege escalation, gaining administrative access (proxy_admin) and bypassing role-based access controls. litellm: LiteLLM: Privilege escalation via API key generation with insufficient permission validation This vulnerability is rated Important because an authenticated LiteLLM proxy user with the internal_user role may be able to create API keys that grant access to admin-only routes, escalating privileges to proxy_admin level. Exploitation requires network access to a LiteLLM proxy instance and valid credentials for a non-admin user account. Products that bundle litellm only as a client library, or that do not expose the LiteLLM proxy management API to untrusted users, have reduced exposure. Affected packages should be updated to litellm 1.83.14 or later when fixes are released. The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Cpe | litellm | Not reported | 1.83.14 | fixed |
| PyPI | litellm | Not reported | 1.83.14 | fixed |
| PyPI | litellm | Not reported | 1.83.14 | fixed |
| Cpe | litellm | Not reported | 1.83.14 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Cpe | litellm | cpe | Not reported | 1.83.14 | Not reported | Not reported | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.83.14 | Not reported | GHSA-QRC4-49GV-MV9M | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.83.14 | Not reported | PYSEC-2026-2598 | Not reported |
| Cpe | litellm | cpe | Not reported | 1.83.14 | Not reported | NVD-CVE-2026-47101 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-47101]
- [https://osv.dev/vulnerability/GHSA-qrc4-49gv-mv9m]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-47101.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1647.json]
[CERT-Bund public advisories] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]