
CVE catalog
CVE-2026-47102
LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint. While the endpoint correctly restricts users to updating only their own account, it does not restric
- Severity
- High · CVSS 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.65% · Oct 25, 2026
A flaw was found in LiteLLM. A user with access to the `/user/update` endpoint can exploit a privilege escalation vulnerability. By modifying their own `user_role` to `proxy_admin`, an attacker can gain full administrative access to LiteLLM, including control over all users, teams, keys, models, and prompt history. litellm: LiteLLM: Privilege escalation through user role modification This vulnerability is rated Important because an authenticated LiteLLM proxy user may be able to modify their own user_role via the /user/update endpoint and escalate to proxy_admin, gaining full administrative access to the LiteLLM instance. Exploitation requires network access to a LiteLLM proxy deployment and valid credentials for a user who can reach the user management endpoints. Users with the org_admin role can exploit this directly. Products that bundle litellm without exposing the proxy user-management API have reduced exposure. Affected packages should be updated to litellm 1.83.10 or later when fixes are released. The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Cpe | litellm | Not reported | 1.83.10 | fixed |
| PyPI | litellm | Not reported | 1.83.10 | fixed |
| PyPI | litellm | Not reported | 1.83.10 | fixed |
| Cpe | litellm | Not reported | 1.83.10 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Cpe | litellm | cpe | Not reported | 1.83.10 | Not reported | Not reported | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.83.10 | Not reported | GHSA-WPFP-GWWC-VWQ6 | Not reported |
| PyPI | litellm | PyPI | Not reported | 1.83.10 | Not reported | PYSEC-2026-2600 | Not reported |
| Cpe | litellm | cpe | Not reported | 1.83.10 | Not reported | NVD-CVE-2026-47102 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-47102]
- [https://osv.dev/vulnerability/GHSA-wpfp-gwwc-vwq6]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-47102.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1647.json]
[CERT-Bund public advisories] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]