
CVE catalog
CVE-2026-47215
UBUNTU-CVE-2026-47215
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.15% · Oct 25, 2026
SingularityCE and SingularityPRO are open source container platforms. Prior to SingularityCE 4.4.2 and SingularityPRO 4.3.9 and 4.1.14, incorrect path-string matching in the singularity.conf limit container paths directive allows a container in a sibling directory such as /data/safe-but-unsafe to be run when /data/safe is allowed under setuid mode. This permits a user to run a container from outside the administrator's configured path allowlist. Installations that do not use limit container paths are not affected. This issue is fixed in SingularityCE 4.4.2 and SingularityPRO 4.3.9 and 4.1.14.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | singularity-container | pro | 2.3.1-2 | vulnerable |
| Ubuntu | singularity-container | pro | 2.3.2-1 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.1-1 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-2 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-3 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-4 | vulnerable |
| Ubuntu | singularity-container | pro | 2.4.2-4ubuntu0.1~esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1build1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.2 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.2+esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3+esm1 | vulnerable |
| Ubuntu | singularity-container | pro | 4.1.1+ds2-1ubuntu0.3+esm2 | vulnerable |
| Ubuntu | singularity-container | 25.10 | 4.1.5+ds4-1 | vulnerable |
| Ubuntu | singularity-container | 26.04 | 4.1.5+ds4-1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: