
CVE catalog
CVE-2026-4870
IBM Qiskit SDK 0.43.0 through 2.5.0 could allow an…
IBM Qiskit SDK 0.43.0 through 2.5.0 could allow an attacker to trigger a segmentation fault leading to a denial of service due to uncontrolled recursion in the parser.
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.27% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "qiskit_software_development_kit",
"ecosystem": "cpe",
"fixed_version": "1.4.6"
},
{
"name": "qiskit_software_development_kit",
"ecosystem": "cpe",
"fixed_version": "2.4.2"
},
{
"name": "qiskit_software_development_kit",
"ranges": [
{
"fixed": "2.4.2",
"introduced": "2.0.0",
"last_affected": "",
"start_excluding": ""
}
],
"ecosystem": "cpe",
"fixed_version": "2.4.2",
"provider_record_id": "NVD-CVE-2026-4870"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: