
CVE catalog
CVE-2026-49097
Improper Input Validation, Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Apache Camel IRC component. The camel-irc producer choos
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.68% · Oct 25, 2026
Improper Input Validation, Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in Apache Camel IRC component. The camel-irc producer chooses the destination of an outgoing IRC message from the irc.sendTo Exchange header (the constant IrcConstants.IRC_SEND_TO, value irc.sendTo); when that header is present it overrides the channel list configured on the endpoint, and the message is sent only to the specified destination. This and the component's other control headers (irc.target, irc.messageType, irc.user.*, irc.num, irc.value) used plain, non-Camel-prefixed values. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into an irc: producer, any HTTP client could therefore set the irc.sendTo header and redirect a message that the route intended for a configured channel to an arbitrary IRC channel or user - exfiltrating the message content to an attacker-chosen nickname, leaking it into a public channel, or delivering messages that appear to come from the bot. No credentials are required when the bridging consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0. Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that set IRC headers via the raw header names must use the CamelIrc* names (for example CamelIrcSendTo) instead of the old irc.* values. For deployments that cannot upgrade immediately, strip the irc.* headers from any untrusted ingress before the irc: producer (for example removeHeaders('irc.*') at the start of the route), and set the IRC destination from a trusted source.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Cpe | camel | Not reported | 4.14.8 | fixed |
| Cpe | camel | Not reported | 4.18.3 | fixed |
| Cpe | camel | Not reported | 4.21.0 | fixed |
| Maven | org.apache.camel:camel-irc | Not reported | 4.21.0 | fixed |
| Cpe | camel | Not reported | 4.21.0 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Cpe | camel | cpe | Not reported | 4.14.8 | Not reported | Not reported | Not reported |
| Cpe | camel | cpe | Not reported | 4.18.3 | Not reported | Not reported | Not reported |
| Cpe | camel | cpe | Not reported | 4.21.0 | Not reported | Not reported | Not reported |
| Maven | org.apache.camel:camel-irc | maven | Not reported | 4.21.0 | Not reported | GHSA-463M-2HR2-Q2J7 | Not reported |
| Cpe | camel | cpe | Not reported | 4.21.0 | Not reported | NVD-CVE-2026-49097 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [http://www.openwall.com/lists/oss-security/2026/07/05/22]
- [https://camel.apache.org/security/CVE-2026-49097.html]
- [https://github.com/advisories/GHSA-463m-2hr2-q2j7]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-49097]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-2203.json]
[CERT-Bund public advisories] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)]