
CVE catalog
CVE-2026-49157
Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-adm
- Severity
- High · CVSS 8.8
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.44% · Oct 25, 2026
Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | activemq | sid | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | trixie | 5.17.6+dfsg-2 | vulnerable |
| Debian | activemq | bookworm | 5.17.2+dfsg-2+deb12u1 | vulnerable |
| Debian | activemq | bookworm-security | 5.17.2+dfsg-2+deb12u1 | vulnerable |
| Cpe | activemq | Not reported | Not reported | vulnerable |
| Cpe | activemq | Not reported | 5.19.7 | fixed |
| Cpe | activemq | Not reported | 6.2.6 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | activemq | source | sid | (unfixed) | not yet assigned | Not reported | [1141385] |
| Debian | activemq | source | trixie | (unfixed) | not yet assigned | Not reported | [1141385] |
| Debian | activemq | source | bookworm | (unfixed) | not yet assigned | Not reported | [1141385] |
| Cpe | activemq | cpe | Not reported | 5.19.7 | Not reported | Not reported | Not reported |
| Cpe | activemq | cpe | Not reported | 6.2.6 | Not reported | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [activemq]Affected
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
- [libactivemq-java]Affected
Source package: [activemq]
Details (4)
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookwormAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
5.17.2+dfsg-2+deb12u1· all · bookworm-securityAffected
nvd · activemq · debian · bookworm; nvd · activemq · debian · 12
[Debian 13 (Trixie)]
- [activemq]Affected
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
- [libactivemq-java]Affected
Source package: [activemq]
Details (2)
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
5.17.6+dfsg-2· all · trixieAffected
nvd · activemq · debian · 13
Observed:
References
- [https://nvd.nist.gov/vuln/detail/CVE-2026-49157]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-49157]
- [https://security-tracker.debian.org/tracker/CVE-2026-49157]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49157.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1741.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]