
CVE catalog
CVE-2026-49468
LiteLLM is a proxy server (AI Gateway) to call LLM…
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, a Host-header parsing flaw in the LiteLLM proxy could, under specific conditions, allow unauthenticated access to protected management routes. The auth layer derived the effective route from request.url.path in litellm/proxy/auth/auth_utils.py::get_request_route(), which Starlette reconstructs from the Host header. A crafted Host could therefore make the auth gate evaluate a different route from the one FastAPI dispatched. This vulnerability is fixed in 1.84.0.
- Severity
- Critical · CVSS 9.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 3.03% · Oct 29, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| PyPIRelease not reported | litellm | 1.84.0 | UnknownSource applicability is not established | PYSEC-2026-388[GHSA-4XPC-PV4P-PM3W] |
| UnknownRelease not reported | litellm | 1.84.0 | UnknownSource applicability is not established | Provider not reported |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| PyPIRelease not reported | litellm | 1.84.0 | UnknownSource applicability is not established | PYSEC-2026-388[GHSA-4XPC-PV4P-PM3W] |
| UnknownRelease not reported | litellm | 1.84.0 | UnknownSource applicability is not established | Provider not reported |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "litellm",
"fixed_version": "1.84.0",
"applicability_unknown": true
},
{
"name": "litellm",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.84.0"
}
]
}
],
"ecosystem": "PyPI",
"fixed_version": "1.84.0",
"provider_record_id": "PYSEC-2026-388",
"applicability_unknown": true
},
{
"name": "litellm",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.84.0"
}
]
}
],
"ecosystem": "PyPI",
"provider_url": "https://osv.dev/vulnerability/GHSA-4xpc-pv4p-pm3w",
"fixed_version": "1.84.0",
"provider_source": "pypi",
"provider_record_id": "GHSA-4XPC-PV4P-PM3W",
"provider_updated_at": "2026-07-18T17:30:30.617013067Z",
"applicability_unknown": true
},
{
"name": "litellm",
"ranges": [
{
"fixed": "1.84.0",
"introduced": "",
"last_affected": "",
"start_excluding": ""
}
],
"ecosystem": "cpe",
"provider_url": "https://nvd.nist.gov/vuln/detail/CVE-2026-49468",
"fixed_version": "1.84.0",
"provider_source": "nvd",
"provider_record_id": "NVD-CVE-2026-49468",
"provider_updated_at": "2026-10-25T23:10:00.167"
}
]
}OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://access.redhat.com/security/cve/CVE-2026-49468]
- [https://bugzilla.redhat.com/show_bug.cgi?id=2491520]
- [https://github.com/BerriAI/litellm/releases/tag/v1.84.0]
- [https://github.com/BerriAI/litellm/security/advisories/GHSA-4xpc-pv4p-pm3w]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-49468]
- [https://osv.dev/vulnerability/GHSA-4xpc-pv4p-pm3w]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49468.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2026/wid-sec-w-2026-1975.json]
[CERT-Bund public advisories] · [FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]