
CVE catalog
CVE-2026-49836
psd-tools: CVE-2026-49836
- Severity
- Medium · CVSS 4.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.19% · Oct 25, 2026
psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.17.1, `SmartObject.save()` writes an embedded smart object to a path taken verbatim from the PSD file. Because that name is attacker-controlled and unsanitised, a tool that extracts embedded objects from an untrusted `.psd` can be made to write attacker-chosen bytes to an attacker-chosen path (absolute or `../`-traversing), outside its intended output directory. A secondary issue in `SmartObject.open()` for external-kind smart objects allows the attacker-controlled `fullPath` descriptor to be used as an arbitrary file read path, enabling exfiltration of the read content to the controlled write destination. Both issues are fixed in v1.17.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | psd-tools | sid | 1.17.4+dfsg.1-2 | fixed |
| Debian | psd-tools | forky | 1.17.4+dfsg.1-2 | fixed |
| Debian | psd-tools | trixie | 1.10.7+dfsg.1-1+deb13u1 | vulnerable |
| Debian | psd-tools | bookworm | 1.9.24+dfsg.1-1 | vulnerable |
| Pip | psd-tools | Not reported | 1.17.1 | fixed |
| Ubuntu | psd-tools | 24.04 | 1.9.28+dfsg.1-1 | vulnerable |
| Ubuntu | psd-tools | 24.04 | 1.9.28+dfsg.1-1build1 | vulnerable |
| Ubuntu | psd-tools | 24.04 | 1.9.30+dfsg.1-1 | vulnerable |
| Ubuntu | psd-tools | 24.04 | 1.9.30+dfsg.1-1build1 | vulnerable |
| Ubuntu | psd-tools | 26.04 | 1.10.7+dfsg.1-1 | vulnerable |
| Ubuntu | psd-tools | 26.04 | 1.10.7+dfsg.1-1build1 | vulnerable |
| Ubuntu | psd-tools | 26.04 | 1.10.9+dfsg.1-1 | vulnerable |
| Ubuntu | psd-tools | 26.04 | 1.12.0+dfsg.1-1 | vulnerable |
| Ubuntu | psd-tools | 26.04 | 1.12.1+dfsg.1-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | psd-tools | source | sid | 1.17.4+dfsg.1-1 | not yet assigned | Not reported | Not reported |
| Debian | psd-tools | source | forky | 1.17.4+dfsg.1-1 | not yet assigned | Not reported | Not reported |
| Debian | psd-tools | source | trixie | (unfixed) | not yet assigned | Not reported | Not reported |
| Debian | psd-tools | source | bookworm | (unfixed) | not yet assigned | Not reported | Not reported |
| Pip | psd-tools | pip | Not reported | 1.17.1 | Not reported | GHSA-2RMG-VRX8-9J2F | Not reported |
Notes
[trixie] psd-tools: Minor issue [bookworm] psd-tools: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [python3-psd-tools]Affected
Source package: [psd-tools]
Details (2)
1.9.24+dfsg.1-1· amd64 · bookwormAffected
dsa · psd-tools · debian · bookworm; dsa · psd-tools · debian · 12
1.9.24+dfsg.1-1· arm64 · bookwormAffected
dsa · psd-tools · debian · bookworm; dsa · psd-tools · debian · 12
- [python3-psd-tools-doc]Affected
Source package: [psd-tools]
Details (2)
1.9.24+dfsg.1-1· all · bookwormAffected
dsa · psd-tools · debian · bookworm; dsa · psd-tools · debian · 12
1.9.24+dfsg.1-1· all · bookwormAffected
dsa · psd-tools · debian · bookworm; dsa · psd-tools · debian · 12
[Debian 13 (Trixie)]
- [python3-psd-tools]Affected
Source package: [psd-tools]
Details (2)
1.10.7+dfsg.1-1+deb13u1· amd64 · trixieAffected
dsa · psd-tools · debian · 13
1.10.7+dfsg.1-1+deb13u1· arm64 · trixieAffected
dsa · psd-tools · debian · 13
- [python3-psd-tools-doc]Affected
Source package: [psd-tools]
Details (2)
1.10.7+dfsg.1-1+deb13u1· all · trixieAffected
dsa · psd-tools · debian · 13
1.10.7+dfsg.1-1+deb13u1· all · trixieAffected
dsa · psd-tools · debian · 13
Observed:
References
- [https://github.com/advisories/GHSA-2rmg-vrx8-9j2f]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-49836]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-49836]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2026-49836]
- [https://security-tracker.debian.org/tracker/CVE-2026-49836]
[Debian Security Tracker] · [FIRST EPSS] · [GitHub Advisory Database] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database]