
CVE catalog
CVE-2026-50159
DEBIAN-CVE-2026-50159
- Severity
- Unknown · CVSS 5.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.60% · Oct 25, 2026
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid is vulnerable to CSS injection via sibling combinator selectors generated from diagram-supplied class or id names. An attacker who can supply diagram text can inject arbitrary CSS into the rendered page, potentially altering the appearance or behavior of unrelated page elements. This issue is fixed in versions 10.9.8 and 11.16.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-mermaid | 14 | 8.11.0+ds+~cs29.13.22-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.2+ds+~cs30.13.21-1.1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.3+ds+~cs26.13.21-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.13.8+~cs10.4.16-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+ds1+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.14.0+~cs11.4.14-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-2~bpo10+1 | vulnerable |
| Debian | node-mermaid | 14 | 8.7.0+ds+~cs27.17.17-3 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.1+ds+~cs26.20.25-1 | vulnerable |
| Debian | node-mermaid | 14 | 8.9.3+ds+~cs29.13.19-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-1 | vulnerable |
| Debian | node-mermaid | 14 | 9.2.2+~2.0.0-2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://github.com/mermaid-js/mermaid/commit/12d472c9ed43f94814b110da8d7a9ae6dd5266ed]
- [https://github.com/mermaid-js/mermaid/commit/7e83f1533318b307764d961906a73377266f4c5e]
- [https://github.com/mermaid-js/mermaid/pull/8022]
- [https://github.com/mermaid-js/mermaid/releases/tag/mermaid@11.16.1]
- [https://github.com/mermaid-js/mermaid/releases/tag/v10.9.8]
- [https://github.com/mermaid-js/mermaid/security/advisories/GHSA-6x64-9x62-f2gx]
- [https://nvd.nist.gov/vuln/detail/CVE-2026-50159]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2026-50159]
- [https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50159.json]
[FIRST EPSS] · [National Vulnerability Database (NVD)] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]